Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Unable to resolve a class com.atlassian.bitbucket.build.BuildStatusService

Mani Reddy July 27, 2019

Hi,

I'm trying to implement, ability to merge to develop only when a source branch on pull request got 6 successful builds. The below script doesn't throw any error when I run it through global script merge check. However, on the pull request it does not allow me to merge and shows that I need 6 successful builds even though I got 6 successful builds on the source branch. When I tried the below script on the repo level script merge check, it is  throwing the below error. 

<pre>org.codehaus.groovy.control.MultipleCompilationErrorsException: startup failed: Script484.groovy: 1: unable to resolve class com.atlassian.bitbucket.build.BuildStatusService @ line 1, column 1. import com.atlassian.bitbucket.build.BuildStatusService ^ 1 error </pre>

 

Did anyone face the similar issue? If yes, please point me in the right direction.

Below is the script I'm using.

 

import com.atlassian.bitbucket.build.BuildStatusService
import com.onresolve.scriptrunner.runner.ScriptRunnerImpl
import com.onresolve.scriptrunner.runner.customisers.WithPlugin
import com.atlassian.bitbucket.auth.AuthenticationContext
import com.atlassian.bitbucket.scm.pull.MergeRequest
import com.atlassian.sal.api.component.ComponentLocator

@WithPlugin("com.atlassian.bitbucket.server.bitbucket-build")

def buildStatusService = ScriptRunnerImpl.getOsgiService(BuildStatusService)
def authenticationContext = ComponentLocator.getComponent(AuthenticationContext)

def mergeRequest = mergeRequest as MergeRequest
def pullRequest = mergeRequest.getPullRequest()
def summaries = buildStatusService.getSummaries(pullRequest.getCommits()*.id)

summaries.values().each {
log.debug("Successes:" + it.successfulCount)
}

def successfulBuild = summaries.values().find { it.successfulCount == 6 }

if ( !successfulBuild ) {
mergeRequest.veto("Unable to merge this pull reuquest", "You need 6 successful builds to merge to develop. Please contact")
}

 

 

 

 

 

1 answer

Suggest an answer

Log in or Sign up to answer
0 votes
Alberto Gonzalez Tajuelo
I'm New Here
I'm New Here
Those new to the Atlassian Community have posted less than three times. Give them a warm welcome!
August 8, 2019

Hi Mani,

 

Did you solved this problem?

Mani Reddy October 23, 2019

Hi @Alberto Gonzalez Tajuelo  The above script worked for me after upgrading the Script runner to latest version.

 

Thanks,
Mani

TAGS
AUG Leaders

Atlassian Community Events