Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Scriptrunner console returning error

Sahai, Harshika April 9, 2020

Scriptrunner console returning error : Failed to post update

2 answers

Suggest an answer

Log in or Sign up to answer
1 vote
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
March 16, 2022

I see that Adaptavist had an issue, SRPLAT-3, which they resolved (13/Dec/19) because they could not reproduce the problem. However, they ran a script that took 5min. I wish they'd run one that takes a lot longer than that in order to get an accurate view of what happens.

It doesn't seem to time out after a specific, repeatable point, even when running the same script. There seem to be a lot of factors including traffic in the application. Sometimes the script finishes after the "Failed to post update" message happens, and sometimes it doesn't.

The suggestion in that ticket of writing to the log only adds to the time it takes to run the script, Even though it's small, it adds up. So, that's not really a great option for long running scripts. I make my scripts as fast as I can make them, but there are limitations to what is available in different scenarios.

Adaptavist, if you come across this, please look into it again. It's still happening.

DH July 21, 2022

I can reproduce it over and over again. I'm trying to narrow it down to a minimal set of code that I can provide to Adaptavist. My script is calling Confluence REST APIs from the Console, on Confluence Data Center.

Chrome Browser tools suggest that the server returns a 504 when I get the 'Failed to post update' error. This must be called by Adaptavist when you press the RUN button.

Screen Shot 2022-07-21 at 10.12.37 AM.png

The payload to this call contains my console script.


It could very well be due to a script taking more than 5 minutes to run...this is just what I'm seeing:

Screen Shot 2022-07-21 at 10.16.41 AM.png

still trying to narrow it down...

Like WW likes this
1 vote
david-guild June 3, 2020

I am getting the same error on file scripts that worked last month.   No changes to the scripts that I am aware of.  Hope somebody from Adaptavist responds.

My scripts are "custom field" cleans up that use the "childIssue" method to find all children of an Initiative or a Feature in our Portfolio project and push data down to all issues that are linked to them.

Was hoping not to have to dig to deep into them, but if there is no answer from Adaptavist soon ............

AUG Leaders

Atlassian Community Events