Are you in the loop? Keep up with the latest by making sure you're subscribed to Community Announcements. Just click Watch and select Articles.

Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Script Runner does not seem to find external .jar properties



I'm using Jira v6.3.13 (WAR, with Apache Tomcat 7 and Java 8) and Script Runner v3.1.4. I wanted to use Jollyday (v0.5.7) with some scripted fields, and downloaded its .jar into Jira's WEB-INF/lib folder. After restarting, it seems to load the jar's classes just fine, but the script is having some trouble finding the jar's internal .properties. When this is executed inside the Script Console:

import de.jollyday.Holiday;
import de.jollyday.HolidayCalendar;
import de.jollyday.HolidayManager;

HolidayManager m = HolidayManager.getInstance(HolidayCalendar.BRAZIL);

Set<Holiday> holidays = m.getHolidays(2019, "br");
return holidays

It returns:

groovy.lang.GroovyRuntimeException: null at org.codehaus.groovy.runtime.InvokerHelper.formatList( at org.codehaus.groovy.runtime.InvokerHelper.toListString( at org.codehaus.groovy.runtime.InvokerHelper.toListString( at org.codehaus.groovy.runtime.InvokerHelper.toListString( at org.codehaus.groovy.runtime.InvokerHelper.toString( at org.codehaus.groovy.runtime.DefaultGroovyMethods.toString( at at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) at sun.reflect.NativeMethodAccessorImpl.invoke( at sun.reflect.DelegatingMethodAccessorImpl.invoke( at java.lang.reflect.Method.invoke( at com.sun.jersey.spi.container.JavaMethodInvokerFactory$1.invoke(
Caused by: java.util.MissingResourceException: Can't find bundle for base name descriptions.holiday_descriptions, locale pt_BR at java.util.ResourceBundle.throwMissingResourceException( at java.util.ResourceBundle.getBundleImpl( at java.util.ResourceBundle.getBundle( at de.jollyday.util.ResourceUtil.getResourceBundle( at de.jollyday.util.ResourceUtil.getHolidayDescriptions( at de.jollyday.util.ResourceUtil.getHolidayDescription( at de.jollyday.Holiday.getDescription( at de.jollyday.Holiday.toString( at org.codehaus.groovy.runtime.InvokerHelper.format( at org.codehaus.groovy.runtime.InvokerHelper.formatList( ... 191 more

It's worth noting that descriptions.holiday_descriptions is a .properties file located inside the .jar (inside the descriptions folder). The locale does not seem to be the problem, since the problem persists if the locale is en_US. I tried adding the properties files inside the WEB-INF/classes as well, to no avail.

Is there some incompatibility with this jar, or with Script Runner trying to import properties into the console? Is there a different approach that could be tried?

0 answers

Suggest an answer

Log in or Sign up to answer
AUG Leaders

Atlassian Community Events