Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Jira Backup with ATM failing to restore

Philip Papp September 4, 2018

I'm trying to restore of our Production environment into our Staging environment. But every time I try to restore Jira using the build in backup and restore utility it fails giving me this error.

2018-09-04 17:43:53,097 JiraImportTaskExecutionThread-1 ERROR jira 1063x602x1 15qec60 /secure/admin/XmlRestore.jspa [c.a.j.bc.dataimport.DefaultDataImportService] Error during ActiveObjects restore
com.atlassian.activeobjects.spi.ActiveObjectsImportExportException: There was an error during import/export with plugin Test Management for JIRA(com.kanoah.test-manager) #4.9.4 (table AO_4D28DD_TRACE_LINK_TYPE):Error executing update for SQL statement 'CREATE SEQUENCE "AO_4D28DD_TRACE_LIN248571635" INCREMENT BY 1 START WITH 1 NOMAXVALUE MINVALUE 1'
at com.atlassian.activeobjects.backup.ImportExportErrorServiceImpl.newImportExportSqlException(
at com.atlassian.activeobjects.backup.SqlUtils.onSqlException(
at com.atlassian.activeobjects.backup.SqlUtils.executeUpdate(
at com.atlassian.activeobjects.backup.ActiveObjectsTableCreator.create(
at com.atlassian.activeobjects.backup.ActiveObjectsTableCreator.create(
at com.atlassian.dbexporter.importer.TableDefinitionImporter.doImportNode(
at com.atlassian.dbexporter.importer.AbstractImporter.importNode(
at com.atlassian.dbexporter.DbImporter.importData(
at com.atlassian.activeobjects.backup.ActiveObjectsBackup.restore(
at com.atlassian.jira.bc.dataimport.DefaultDataImportService.restoreActiveObjects(
at com.atlassian.jira.bc.dataimport.DefaultDataImportService.performImport(
at com.atlassian.jira.bc.dataimport.DefaultDataImportService.doImport(
at com.atlassian.jira.task.ImportTaskManagerImpl$
at com.atlassian.jira.task.ImportTaskManagerImpl$
at java.util.concurrent.Executors$
at java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.util.concurrent.ThreadPoolExecutor$
Caused by: java.sql.SQLSyntaxErrorException: ORA-00955: name is already used by an existing object

at oracle.jdbc.driver.T4CTTIoer.processError(
at oracle.jdbc.driver.T4CTTIoer.processError(
at oracle.jdbc.driver.T4C8Oall.processError(
at oracle.jdbc.driver.T4CTTIfun.receive(
at oracle.jdbc.driver.T4C8Oall.doOALL(
at oracle.jdbc.driver.T4CStatement.doOall8(
at oracle.jdbc.driver.T4CStatement.doOall8(
at oracle.jdbc.driver.T4CStatement.executeForRows(
at oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(
at oracle.jdbc.driver.OracleStatement.executeUpdateInternal(
at oracle.jdbc.driver.OracleStatement.executeUpdate(
at oracle.jdbc.driver.OracleStatementWrapper.executeUpdate(
at org.apache.commons.dbcp2.DelegatingStatement.executeUpdate(
at org.apache.commons.dbcp2.DelegatingStatement.executeUpdate(
at com.atlassian.activeobjects.backup.SqlUtils.executeUpdate(
... 19 more


I've tried clearing the database, using another database, installing the plugin before and after restoring but I always get the same error. It looks like the restore script is trying to write AO_4D28DD_TRACE_LIN248571635 into the database twice.

I've edited my backup to removed everything pertaining to ATM and it restored without any issues/errors.

Wondering if anyone has run into this issue or has any suggestions.

1 answer

Suggest an answer

Log in or Sign up to answer
0 votes
Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
September 10, 2018

Hey Philip, 


Have you tried deleting the Sequences for this table: ORA-00955: Name is already used by an existing object


Can you also let us know what add-on this table is from?  You can check in your Production Jira under Administration > System > Plugin Data Storage 




Philip Papp September 11, 2018

Hi Keri,

The error is coming from (Adaptivist) Test Management for JIRA.

I have tried deleting the sequence, restoring into a clean DB all yield the same result. The only thing I've gotten to work is editing the backup file by changing the autoIncrement to false instead of true as per this:

This allows the restore to proceed with no errors and the plugin seems to work properly. But I'm not sure what other issue this could lead to.



Atlassian Team
Atlassian Team members are employees working across the company in a wide variety of roles.
September 11, 2018

I'm glad you managed to workaround around this issue - I've added some notes to the bug to say you experienced it in restoring this add-on too. 

Thanks for sharing your resolution with the community! We appreciate it! 

AUG Leaders

Atlassian Community Events