Are you in the loop? Keep up with the latest by making sure you're subscribed to Community Announcements. Just click Watch and select Articles.

Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


How to parse excel spreadsheet from scriptrunner


Hi All,   I am trying to pull data from an excel spreadsheet.   I have found several excel parsers for groovy that are based on apache poi which seem like what I need.

But I am having trouble just loading the libraries,  

I  tried using  grape to get this to resolve.

/*import groovy.grape.Grape
groovy.grape.Grape.grab(group:'org.apache.poi', module:'poi', version:'4.0')
groovy.grape.Grape.grab(group:'org.apache.poi', module:'poi-ooxml', version:'4.0')

@Grab(group='org.apache.poi', module='poi', version='4.0'),
@Grab(group='org.apache.poi', module='poi-ooxml', version='4.0')

import org.apache.poi.hssf.usermodel.*
import org.apache.poi.sssf.usermodel.*

InputStream inp = new FileInputStream("C:\\temp\\testFile.xlsx")
Workbook wb = WorkbookFactory.create(inp);

  Error grabbing Grapes -- [unresolved dependency: org.apache.poi#poi-ooxml;4.0: not found,unresolved dependency: org.apache.poi#poi;4.0: not found] j

Failed, on all saying that org.apache.poi was unresolved.

So I have downloaded the apache.poi jar files version 4.0 and placed the 6 jar files into web-inf/lib folder

Now I removed the grapes code and ran it and I get no errors on the import lines but it says it cannot resolve Workbook.  (Even if I scope it to

I tried doing import and that does fail.

But the documentation for java says that is where it is located.


I am running the above script from the Jira->Add ons->Script Console

Scriptrunner is 5.5.2

Jira 7.5.2


Any Ideas??



2 answers

Suggest an answer

Log in or Sign up to answer

Hi @OToole ,

Did you find a way to do this ?


0 votes
Vikrant Yadav
Community Leader
Community Leader
Community Leaders are connectors, ambassadors, and mentors. On the online community, they serve as thought leaders, product experts, and moderators.
Sep 07, 2021

Hi @OToole  Kindly check below post for reading CSV file in Script Runner :-


AUG Leaders

Atlassian Community Events