Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


API to update Test Run in Adaptavists to link new test cases


I have an already created Test Run in Jira with Adaptavists Test Management. Now I need to link more test cases to the same Test run but have to do it only via API. I'm using Postman. 

I refer the API reference -  but can not see a solution here since no way to update an existing Test Run via API to link new test cases. Is there any other way to do this ? 

3 answers

Suggest an answer

Log in or Sign up to answer

hey, I have pretty much same problem, I'm using ARC and while I'm trying to use GET method with https://<jira URL>/rest/atm/1/testrun/search/ - I get 404 Not Found error...with 1.0 I get 400 Bad Request, same happens with testplan etc.

Hey  Adrian,

The URL having 1.0 is the correct one. What is probably missing here is the search query, for example:

GET https://<jira URL>/rest/atm/1/testrun/search?query=projectKey IN ("JQA", "DEF") AND folder = "/Orbiter/Propellant"

That should work fine. Please take a look on the docs for more query examples:



Any update on above issue pls ?

Hey @Lahiru Wijesinghe,

I've just replied your question above. Let me know if that works fine :)



Hi @Edu Car,

This is possible since the last release of Test Management for Jira (TM4J) v4.7.0. You can input test results to your test run by using one of these two endpoints:


POST/PUT /testrun/{testRunKey}/testcase/{testCaseKey}/testresult

POST /testrun/{testRunKey}/testresults


If the test result is linked to a test case that doesn't belong to the test run, it will be automatically added to it. So you can, for example, create an empty Test Run and post your test results to it.

Let me know if that's clear enough for you?



Hi @Vitor Pelizza ,

You mean the full url should be like below or something else.




Best Rgds


Hey @Lahiru Wijesinghe ,

As per the documentation, the full URL should be:


For example:

POST http://your-jira-base-url/jira/rest/atm/1.0/testrun/{testRunKey}/testcase/{testCaseKey}/testresult

Here is the link to the docs:

Hope that works fine for you.



Hi @Vitor Pelizza @

Thanks a lot Vitor.Tried using Advanced Rest client , but response gives as '

title>Oops, you&#39;ve found a dead link. - JIRA</title>




Hey @Lahiru Wijesinghe ,

No problem, glad to help. Let's move on :)

Well, there is something wrong with the URL obviously. Could you please paste you Jira URL here, and then I can try to make it correct? You can just replace some names if you don't want to disclose it...


Hi @Vitor Pelizza 

Its ,

https://<jira URL>/rest/atm/1.0/testrun/ASDE-2043/testcase/ASDE-2042/testresult

Alright, so the keys you are using doesn't seem to be correct. The test run key should have -C and the test case key should have a -T. For example:

https://<jira URL>/rest/atm/1.0/testrun/ASDE-C2043/testcase/ASDE-T2042/testresult

@Vitor Pelizza 

This is a GET url right ? i still get same issue . :-( .Is there a body content to send if its a POST url ?

Hi Lahiru,

No, actually this should be a POST or PUT operation, as per my first answer. If you want to try a GET, just to see it working and validate everything is correct, you can try this one:

GET https://<jira URL>/rest/atm/1.0/testcase/ASDE-T2042

This should retrieve the test case with key ASDE-T2042.

I recommend taking a look at the documentation, you will find all the endpoints there, available operations for each of them and request body examples:




Hi @Vitor Pelizza ,

Thanks a lot now am getting  a Null for URI message.I think its an issue on atm or version..One last question how do i get the version of atm ?



Hey Lahiru,

You can check that on the configuration area of the feedback panel:


AUG Leaders

Atlassian Community Events