Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,362,849
Community Members
 
Community Events
168
Community Groups

Forcing a Linebreak "\\" --- Issue Comment --- Groovy

JIRA Version 4.4.4 Standalone

I have a postfunction groovy script that creates a Comment within an issue.

The Comment field is configured for Wiki Style Rendering.

I'd like to have a forced linebreak within the comment --- via the groovy script.

The \\ character set produces a \ in the wiki renderer --- via the groovy script.

If I use \\\ character set, it produces an error.

Via groovy, is there an easy way to insert a linebreak for use in a comment using Wiki Style Rendering?

Thanks!

3 answers

1 accepted

Comments for this post are closed

Community moderators have prevented the ability to post new answers.

Post a new question

3 votes
Answer accepted
JamieA Rising Star Nov 19, 2012

It should be "\\\\". Or use single-quotes then you shouldn't need to escape, ie '\\'.

jamie

Thank you, Jamie! Have a good rest of the week.

Hi @JamieA 

I am trying to add a line break in my comment which is like 

"Open access for ${linkedIssue.getSummary()} branch is extended now until ${dateformat.format(issue.getCustomFieldValue(plannedrcDate))}" . 

How can i insert a new line comment at the end

For me i found the string 

+ '\r\n' + '\r\n' + 

 

works really well to put carriage returns in between my groovy string values, to insert in another work order description or comment using a workflow.

Hi!

For line break, I usually use this (just for info, if anoyone else looking for this):

String newLine = System.getProperty("line.separator");

Gyuri

JamieA Rising Star Nov 19, 2012

Fair play, but I don't think that's necessary unless you're planning on write a text file that can be read in windows notepad. Browsers and databases seem to treat \n correctly.

Somehow /n doesn't worked for me.

Dear György, thanks so much for this information.

JamieA Rising Star Nov 19, 2012

> Somehow /n doesn't worked for me

Should be \n, not /n

TAGS

Atlassian Community Events