Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root


1 badge earned


Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!


Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.


Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!


Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
Community Members
Community Events
Community Groups

Why is my Trello search function not working?

Lately, I have been having an issue with my Trello search function. I am a purchaser at my company and I use Trello to keep track of all purchase orders. We order a lot so I constantly have around 200 cards on my board. I title the card by the purchase order number so that I can search by the number if I need to pull them up.

Usually this has worked perfectly with no issues. Recently, I type in the order number and it just shows that is searching and it will never find it. I'm not sure if this is due to the amount of card I have on my board or something else. I archive every order once it has been received just in case I need to go back to it. This may have something to do with it as well but I am not sure. 

I guess I wanted to see if maybe Trello has a limit on how many card you can have on your board or archived. Maybe I just have too much stuff on that board and I need to get rid of some things. Just want to get an idea of what I should do to fix this.

1 answer

0 votes

Hey Darien

Boards function better with the lesser amount of cards, but 200 should be no issue. And having a lot of archived cards shouldn’t be the issue either. 

Have you tried this search from another web browser? Wondering if a cache clearing in your current browser will clear up the issue. 


I have noticed that after I refresh the page, the search function seems to work. After a while of using Trello it will eventually stop searching. I guess a simple refresh fixes that problem. At least for a while. 


Thank you!

Hey Matthew, I have exactly the same problem as you but even though I change the web browser or clear the cache or reload the page but still none is working. please help me out.

Suggest an answer

Log in or Sign up to answer

Atlassian Community Events