It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Trouble with Butler Automation Checklist Rule Edited

Hi!

Im brand new to butler and having some trouble getting (what I thought was) a simple rule happening :( ! Im trying to shift a card to the next list on completion of a checklist (that only has one item).

I have attached a screen shot of my rule ( and have also tried a few other formulas with no luck) .

Any advice would be much appreciated :)Screenshot (26).png

2 answers

1 accepted

1 vote
Answer accepted
Esme Crutchley Community Leader Apr 08, 2020

Hi @Evanthe Dunn 

Welcome to the Community!

Unfortunately, the screenshot hasn't attached, do you want to try uploading it again so we can take a look?

Esme :)

:) Yep - sorry - done!

No worries!

I would suggest that you open your Butler account and see if there's a problem there. To do this, open the board that's being troublesome, click on Butler, then bottom left click on 'Account'. This will show you all the stats for that board (and the whole account, but we're focusing at the moment on this specific board)

If you've used all your allowance for the month, it'll show up on the menu and would stop your rules from working:

Screenshot 2020-04-08 at 11.46.05.png

 

Alternatively, you can check the 'Usage Log' by clicking on the tab, and there it will show what rules have run and whether there were any problems - usually indicated by a red mark (I think it's a red cross but I could be wrong!).

From there you can see what the rule was having problems with, because it should indicate exactly where the rule failed. From this you should be able to adjust your rule accordingly (it's pretty hard to change it if you don't know where it went wrong!). If you can't work it out, please feel free to upload screenshots and we'll do a process of elimination and get the pesky thing working!

Esme :)

Like Evanthe Dunn likes this

Thanks for the suggestions Esme! Ive had a look at all of these things and nothing is jumping out at me. The usage log does not load any further entries when I click "Load more" ... Im stumped ???Screenshot (27).pngScreenshot (28).pngScreenshot (29).png

Esme Crutchley Community Leader Apr 08, 2020

Hi @Evanthe Dunn 

Don't worry, what's happened is it's loaded more that you can scroll through, I thought the same thing when I did mine, so don't worry, it's not labelled very well! So it has worked, but you can't see it until you scroll down!

With your cursor in the log section, just scroll down and you'll see all the ones that have happened, then you can pick the one that's gone wrong and send that screenshot!

Thanks Esme. There is definitely nothing more there re: the dodgy command. The other rule I have set is working, and more logs have listed since the first screen shot, and Im able to look through them. But - still nothing on the checklist command :( It doesn't even register.

0 votes
Esme Crutchley Community Leader Apr 08, 2020

Actually, that’s helpful too!

if it’s not there, it means that it’s not trying to run, basically it’s possible that’s it’s not switched on. It could be that it’s been enabled on a board that isn’t the one it should be, rather than this one, or it might not be enabled at all, which is an easy fix if this is the case.

Go to the list of rules, find the one we’re taking about and make sure that the little blue ‘enable’ button is on. This should be on the left straight after the rule. 

If you want to find all the rules that are enabled on a specific board, open Butler, click on Rules, then top left will say ‘all’ - click on that and change it to ‘enabled’ which will show you just the rules that are enabled on the board you’re on.

let me know if this works, if not, we’ll try something else! It will NOT prevail!!

Screenshot (30).png

Enabled ... (Waaah!!!)

Esme Crutchley Community Leader Apr 08, 2020

OK so another random one, are the initial contact cards on that board?

Another random one, is the checklist name right? There isn't a random space at the end or anything?

I would say that because it's the trigger, and there's nothing happening in the Butler logs, it has to be the trigger that's stopping it. For some reason, that trigger isn't triggering anything, this bit:

Screenshot 2020-04-08 at 14.49.40.pngisn't triggering anything.

Check the checklist name and the list name and make sure that they're both right, maybe? 

Like Evanthe Dunn likes this

Yes, the "Initial Contact"cards are on the board.

I checked the name, no spaces, and even changed the name to "Work", created a new rule, and no luck. We have tried rules with both completed "item" , and completed "checklist" and its not working. 

Ive just created the rule using a different checklist as the trigger (this one has 3 items), and the command has worked.

Do you think the repetition of "Site Visit" within the command could be causing the issue?

Its 3 times in the original command

1/ Checklist name "Site Visit"

2/ Checklist Item "Site Visit Scheduled"

3/ Move to list name "Site Visit"

??

Off to check this now!

Like Esme Crutchley likes this

I managed to get the command working using a different checklist within the came card.

I thought the issue could be using the words "site visit" 3 times within the command. I changed thee and still no luck. I cant figure it out :( 

Like Esme Crutchley likes this

***SOLVED***

I deleted the original checklist, that was not triggering the command, created a new one and BINGO.

That took me waaaay too long! 

Like Esme Crutchley likes this

Thank you for all of your suggestions and patience! Much appreciated! Learnt a lot anyway ;) !!

Like Esme Crutchley likes this
Esme Crutchley Community Leader Apr 09, 2020

Woohoo!

Awesome!

I'm glad you sorted it!

Hello I have a business account how do i get unlimited butler

Esme Crutchley Community Leader May 04, 2020

Hi @itzik1000 

Welcome to the Community!

Unfortunately, BC doesn't give unlimited Butler, only Enterprise does:

Screenshot 2020-05-04 at 12.14.11.png

https://help.trello.com/article/1181-butler-features-and-quotas

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Trello

Develop a new Habit during Lockdown

If you had to thrive a new habit during a lockdown, what would it be? Trello

1,616 views 15 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you