Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,467,463
Community Members
 
Community Events
177
Community Groups

Trello won't load properly

Used Trello for 2 years no problems. Suddenly wont load fully. I get the top of the page and the Trello logo 'bounces' but nothing happens. I can get to "my boards' and select one and nothing happens. I am using a Mac Book pro.

Can you help please. I have tried log out/ log in but not joy

Thanks

Geoff Boldero

 

1 answer

1 accepted

0 votes
Answer accepted
Brittany Joiner Community Leader Mar 17, 2022

@Geoff Boldero is it still not working? might have been an outage, but i don't see any reported on the Trello status page.

Thank you Brittany, but as soon as I updated my operating system everything is now fine.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events