It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Trello API webhook stopped working

We've been creating Trello webhooks automatically via the API for the last few weeks with no problems. Now within the last day or two this has stopped working. We are now getting the following error - "did not return 200 status code, got 503".

I've checked and can confirm that our webhook callback url successfully returns a 200 code when making a HEAD request to it.

Would massively appreciate any help with this matter.

1 answer

0 votes
Iain Dooley Community Leader Feb 01, 2019

@DanielKeeble Usually when things go pear shaped like this I like to strip things back to the simplest possible case and test it.

For example can you set up a new URL that only returns 200 for a HEAD request and does nothing else, and if you do this does the webhook register successfully? Eg.

https://github.com/iaindooley/trellinator-buffer/blob/master/nginx_template.txt

Then if that works, start adding things in until it breaks! 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Trello

Develop a new Habit during Lockdown

If you had to thrive a new habit during a lockdown, what would it be? Trello

1,597 views 14 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you