Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Slack PowerUp stopped working

Dima Chi I'm New Here Dec 23, 2020

We've been using slack integration for quite a while. It stopped working around 16 hours ago.

5 answers

1 accepted

2 votes
Answer accepted

Back story - we submitted a new version of our app to Slack but when they put it into the slack App Store it seems like it’s being treated as a new app (ie it is not using previous authorizations like it is supposed to). This could be Trello’s fault. This could be Slack’s fault. Regardless, we both apologize as this is an experience we did not intend to happen and we are trying to figure out how to resolve it 

 

BUT, it does seem like if you don’t want to wait just redoing the whole app and reinstalling it on the slack side would fix it. 

I removed the Trello app from my Slack workspace. Removed Trello addon from my Trello board. Made all the linking (accounts, slack channel to post, etc.) from scratch but the activity notifications from Slack doesn't work.

Like # people like this

Redid everything and elements of the integration work but the activity notifications do NOT work still.

Like Darian James likes this

I've invited Trello into the slack room as advised above but still have No longer authorized to post alerts on behalf of the creator. errors on my existing integrations. 

If I create a new one, it also reverts back to the above error state.

Similar to what Maksym said, if you:

1. remove your power up settings on Trello by pressing "Remove Personal Settings" on the Slack Power-Up

2. use the "/trello reset" and "/trello setup" commands on Slack

you should be able to relink your account.

Done it many times, also in the exact sequence of your message. Nothing happens.

The account relinking seem ok when setup but when I add a new card nothing is notified on Slack.

If in Trello I go to "menu" (right panel), Slack, Edit settings of the powerup, I receive this:

trello_slack_problem.png

Like Brett Hill likes this

And if I click on the edit "Modifica" link on the above screenshot I receive this:
"You are not authorized anymore to publish alerts on behalf of the creator/author"

trello_slack_problem_1.png

Bryan Liao Atlassian Team Dec 28, 2020

What happens when you try to edit the alert?

I can change the status of each checkboxes checked/not_checked or I can delete the alert with the orange button in the bottom of the modal. I've done it many times, editing and also completely deleting and recreating the alert and the linkings.

Nothing changes.

Like Brett Hill likes this

Have you tried manually revoking the token for the Slack Power-Up? 
You can revoke it by going to your account settings page, and pressing the Revoke button next to the Slack power-up under Applications. 

Also try disabling and re-enabling the power-up afterwards.

And then run the same slack commands to relink the board.

After your message I revoked the app auth in my account settings page. Cleared anything in account linkings. Done all the setup from scratch, nothing changes.

Bryan Liao Atlassian Team Dec 28, 2020

Is this a personal board or a team board?

I have free Trello account and this is a team/group board.

I have a paid account with a help desk and security team that I have to pass this by so re-authorizing in certain worlds is not as easy, especially since it affects the entire workspace. Hopefully I will get approval and will report back on if the above steps do indeed work.

Like mentezar likes this

After getting approval, I re-auth'ed, used  "/trello reset" and "/trello setup" commands in my private Slack channel and I still get this message: No longer authorized to post alerts on behalf of the creator.

 

This powerup has been critical in knowing when new requests have been made to my business unit.

What other steps are there to get this working?

Like # people like this

@Tricia is the exact error message I receive (translated in Italian). Hope they will find a solution.

Like Tricia likes this
NC I'm New Here Dec 29, 2020

I hope they fix this. Having the same problem here.

Like Tricia likes this
Bryan Liao Atlassian Team Dec 30, 2020

Can you go to your team page and unlink your current slack channels and then press Add to Slack to re-link it?

Trello.com/teamname/account > Settings tab > Scroll down to Slack Team Linking > Change > Unlink

We have the same issue. The error message is "No longer authorized to post alerts on behalf of the creator."

Try /invite @trello back to that channel and that should help

Like # people like this

I got the same error, how do I fix this? 

Dima Chi I'm New Here Dec 23, 2020

The fix is posted literally above your comment.

This is the error I get - 

 

A valid member name is required.

I tried all the suggestions, nothing worked. Now it's just working again!

I've tried to invite @Trello again, recreated PoweUp and subscriptions, removed app on the Slack side - nothing helps, messages don't work.

We're using free Slack workspace and Trello, private board and Slack channel.

>No longer authorized to post alerts on behalf of the creator.

to fix it I had to change app name, board name, delete from all workspaces, powerpurs (and clean up all credentials firstly). I don't remember the right sequence, but now it works.

Check "Slack Team Linking" 

So, this appears to have started working again, but now it's posting notifications via a specific user and not the trello bot/user. What gives?

Bryan Liao Atlassian Team Dec 31, 2020

We rolled out a change to our Slack Power-Up that had seemed to invalidated the bot token on some workspaces. We added a fix to use the user's token if the bot token fails.

Remved association from team, removed linking informations from power-up (step already done many times) but today it started working again. Thanks.

@Bryan Liao The bot token still fails for us and it uses my token instead. However, I'm the user who needs to be notified about changes in Trello and Slack will not notify me about "my" messages.

@Bryan Liao Will you continue to work on a real solution to this?

Bryan Liao Atlassian Team Jan 21, 2021

@Remmer Janssen I believe if you invite the bot to your channel again, the notifications should use your bot instead of your own token. /invite @trello

Can anyone from Atlassian create a video to show us what you are doing?  I have tried to do all of these things.  I can't add another slack team and I can't remove the old slack teams - even on the Slack side.  I revoked.  I removed the workspaces.  I removed personal data.  Nothing.  Why not just show us??!!

Does this have anything to do with Slack now being a part of Salesforce?  Should we add Salesforce and see if Slack works there?  :(

@Bryan Liao OK, I tried again. I removed the personal settings in Slack, removed the Power-Up from all boards except for one Trello team, invited Trello to the dedicated Slack channel, unlinked the Slack team from the Trello team and linked the Slack and Trello team again. Now it is working again

Bryan Liao Atlassian Team Jan 25, 2021

@Suzie Weisband Here is a video you can refer to for relinking slack teams and users with Trello:

https://drive.google.com/file/d/1hrf9Or1Qv0W_EWJAJ47Qn7BfslsacIeC/view?usp=sharing

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Posted in Trello

Introducing: A Whole New Trello

After a decade of growing the most ubiquitous visual framework for productivity and project management, we are evolving Trello’s boards, lists, and cards model to bring context to content and help te...

611 views 23 21
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you