Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,457,003
Community Members
 
Community Events
176
Community Groups

POSSIBLE BUG? Butler Trigger "When item is added to checklist by anyone" does not work as expected

Hi, I am experiencing a very similar issue. Here's how to replicate:

  • Log in as User A 
  • Go to a certain board (lets call it Blue Board)
  • Create a Rule: "when an item is added to checklist "Tasks" by anyone, post comment "User A rules ({checklistitemname})"
  • Enable this rule on another Board (say, Red Board)
  • Log in as User B
  • Go to Blue Board
  • Create a Rule: "when an item is added to checklist "Tasks" by anyone, post comment "User B rules ({checklistitemname})"
  • Enable this rule on Red Board

Expected behavior now would be that if ANY user adds a checklist item to a checklist named "Tasks" on ANY card on EITHER board (ONE or TWO), both rules should be triggered and two comments should be posted. However, this is what happens:

  • Log in as either User A or B 
  • Go to the Blue Board
  • Open any card, create checklist "Tasks", add item "First blue task"
  • Both rules run and both comments are posted - OK
  • Go to the Red Board
  • Open any card, create checklist "Tasks", add item "First red task"
  • Only the rule created by the current user will run and only one comment is posted - NOT OK

Notice that the board in which the rule is created is interfering with the behavior. This should not be case.

Also if a third user (User C) adds tasks in any of the cards, both rules are triggered on the Blue board (where the rules were created) but NOT on the Red board (where the rules are ENABLED).

I have actually created the Blue and Red boards and made them publicly visible, in case anyone here wants to take a look:

Blue: https://trello.com/c/kNJ141jV/1-only-blue-card

Red: https://trello.com/c/YtSL570V/1-only-red-card

 Any help would be greatly appreciated

Thanks in advance

1 answer

1 accepted

1 vote
Answer accepted

@Ricardo B. thank you for the detailed report. I've forwarded this to the Butler team to dig into and fix as soon as possible. Definitely seems like something's amiss here.

I'll update you here once we've figured it out and deployed a fix.

 

As a temporary workaround, you might be able to solve this issue by going to the board that's having issues, and disabling and re-enabling the command there, using the "Enabled on this board" checkbox. That should re-setup all the stuff that's needed for rules to trigger, hopefully including the bits that we're missing to trigger the command properly now.

 

@Felix Thank you for the prompt reply.

Glad to say your temporary workaround WORKED!

I disabled and re-enabled the commands and both worked as expected on the red board.

Looking forward for a definitive solution.

Cheers

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events