It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

New team members not receiving their verification email from Trello.

We use Trello free version. When a person leaves the team, I delete them from a board and send the copy link to join Trello to the new person to join that board. The new member clicks the link to Trello which says they have sent an email of verification to the participant; however, the new member does not receive the verification email. We have checked all folders, we have waited days, we have tried multiple times. We have confirmed the correct spelling of the address, etc. Our tech team has removed all protocols etc., and yet, the email does not come. What is the secret to the new person being able to join the board? Am I doing something wrong on their set up which is keeping their email from going through? 

1 answer

0 votes
FUN MAN ANDY Community Leader Aug 22, 2019

@Nicholas Olsen : So to summarise, whilst the member does click the sent link, it doesn't verify and thus they cannot join the board? 

I've heard of members being able to access a board and then not have editing rights, but that's just being forgetful on the settings side - this is a new one to me.

Sounds like you've been quite rigorous but some simple questions just to check:
Have you reviewed all possible settings and membership rights within the Board? 
Can you see the person correctly added to your board?
Have you tried both "send invitation"  "send a link"? 

If all else fails log a ticket with Atlassian:
https://support.atlassian.com/products/

 

Untitled.jpg

Greetings Andy, thanks for responding.

When I copy the "invite with link" into my email and send it to the new member, they click the link which takes them to a screen that says "we just sent you an email to verify your email" (or something along those lines); however, the email never comes. The new member has clicked the resend an email confirmation multiple times, but it never comes. I have also just clicked "send a email invite" but it never comes. 

The new member shows up under the invited section of the board, but without the verification of the email, I cannot change their rights or access to the board. I have also looked over the all the possible settings and membership rights a couple different times, but have not come across anything which seems to be off or preventative. 

I will try to log a tick, thank you.

Like FUN MAN ANDY likes this
FUN MAN ANDY Community Leader Aug 23, 2019

Welcome!
It is such a strange issue.
The only other roadblock is that the tokens for the total account are maxed out so new members can be added but the verification blocks... but that's not even a functionality in Trello... so can't be that.
Good luck with the ticket!

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Trello

Develop a new Habit during Lockdown

If you had to thrive a new habit during a lockdown, what would it be? Trello

1,506 views 12 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you