Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,465,994
Community Members
 
Community Events
176
Community Groups

Copy Custom Field Data via Automation between Boards

Does anyone know how to solve this problem?

I need to move a card into a list with a custom field set and for each card attachment (over multiple boards), copy the custom field value.

The automation will work within the current board, but not over multiple boards... the logs simply say it has been cleared on the attachments.

I know the rule works as if I manually enter a value for the custom field within the automation, it will copy through.

Thanks,

Anthony.

2 answers

1 accepted

0 votes
Answer accepted
Hannah Morgan Community Leader Jul 12, 2022

Hi @Anthony ! Are you able to share the command you've set up? As far as I know, the {customfieldvalue} variable only works when the trigger contains the custom field. E.g. "when X custom field is set, for each card linked in the attachments, set custom field X to {customfieldvalue}."

When a card with custom field "Site Address:" set is added to list "IFC Ready for production", for each card linked in the attachments, set custom field "Site Address:" to "{carddescription}_{{%Site Address}}+{{%Field Name}}_{customfieldvalue}="

The result I get for each linked card is: 

_+_=

 

Obviously "Site Address:" is filled with content and every variable used all displays a blank. Thoughts?

Obviously "Site Address:" is filled with content and every variable used all displays a blank. Thoughts?

I have worked it out. It will not action upon a moved card trigger, it will only work if the custom field has been set.

I will have to change my process to accomodate your answer above. 

Thanks,

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events