Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,460,113
Community Members
 
Community Events
176
Community Groups

Card button inexplicably stopped working

Hi - I hope someone can help.

I have a card button that creates a daily to-do list for me by pulling together all the cards with a due date of today into linked items in a check-list.  The title for this to-do list card is generated as "To Do List {date~ M/D/YYYY}.  (This button still works perfectly, and I think the title is the only important piece for my question, but if you need to know more specifics about the list creation button, I can provide those details as well).

Because I occasionally forget to add a card, change a due date, or someone asks me for something during the day that needs to be added to that day's list, I also created a button that adds the open card to the current day's To Do list card's checklist as a linked item.

The following screenshot shows the actions for that button.

card button commands.jpg

At 9:05 AM on January 14th, this button worked.  At 9:50 AM on the same day, I tried to use the button to add another card as a linked item on my To Do list card, and I got the error "I couldn't find a card named "To Do List 1/14/2022"."  I made no changes to either button between the time it worked and the time it didn't.

I tried the button again this morning, and got the same error (except it was "To Do List 1/18/2022"), so it doesn't seem to be just a random one-time glitch.

Does anyone see something I missed that might explain why this no longer works?  Or have any other ideas I could try?

Thanks!

1 answer

1 accepted

0 votes
Answer accepted
Felix Atlassian Team Jan 20, 2022

Hey @Leslie Rieger - I can reproduce the issue you're describing, and I'm puzzled as to what's going on. The team's looking into it. I can get it to work without the date variable, so likely some bug crept in that's affecting this.

I'll post an update here once we've figured this out & sent a fix out.

Thank you!  At least now I know I'm not crazy. :)

Felix Atlassian Team Jan 20, 2022

Update

@Leslie Rieger I think we've figured this one out (and it's not a bug!).

Your button command's date variable includes an extra space, which seems to be trimmed in a bunch of places, like on the front of Trello card, so it's really hard to spot.

I've managed to get your example working, by changing:

To Do List {date~ M/D/YYYY}

to

To Do List {date~M/D/YYYY}


Note the removed space between "~" and "M".

Could you give that a shot and let me know if that fixes the issue for you too?

That worked! Thank you so much!

Like Felix likes this

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events