Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Butler won't copy my checklist...it says it doesn't exist/ can't find it...

So I'm using the Butler power up. 

I set up a button where if you press it moves a card & adds two checklists.

The first checklist shows up just fine, but the second one, it  says it can't not find a checklist by that name (even though I cut and pasted the both names of the checklist to butler to avoid error.  

It still says it can't find a checklist called " blog post checklist - guest post" . I've tried adding "" even and that doesn't work. I even tried getting rid of the - in case that was throwing things off. 

I try resetting the button to only apply one checklist (the one it can't find) thinking maybe two checklist was too much for it but still it won't work. 

2 answers

0 votes
Iain Dooley Community Leader Sep 16, 2019

@Kate it's a good idea to send a screenshot of the rule, preferably in the rule creator interface as the devil is often in the detail ... 

Thanks @Iain Dooley  I made the trello staff this little video: https://www.loom.com/share/c593d4e5da684f90859c0792b7c44c2d

Still haven't heard back yet. :-(

Iain Dooley Community Leader Oct 01, 2019

@Kate hey sorry for the delay, just watched the vid, that error message is pretty definitive: can't find checklist on card, link provided, click the link, checklist is there, copy/paste error unlikely. Hmmm .. did you hear back from support yet?

If this still isn't working here's a Trellinator command that will copy all checklists from a card with the same name as a list into which a card is moved:

https://gist.github.com/iaindooley/15d292334a935bcff3a3ae43d61337a3

This will allow you to have a relatively flexible system for a board (or all boards if you set it up globally). But it won't give you a button. You'll need to move the card, and then the checklists for that list will be added.

You can read more about Trellinator here:

https://community.atlassian.com/t5/Marketplace-Apps-Integrations/Introducing-Trellinator-Automate-Trello-with-Google-Apps-Script/ba-p/925271

0 votes
Katrin Anger Community Leader Sep 18, 2019

Hi @Kate 

Please copy the command text in here, or even better, insert a screenshot.

Than we can most likely help you with that issue.

@Katrin Anger  I made a little video for the Trello staff on Friday, here's what's going on https://www.loom.com/share/c593d4e5da684f90859c0792b7c44c2d

@Kate 

Hi Kate, thanks for video. It definitely helped to understand what you are struggling with.

I set up the same card button and did a test run with a card that had one checklist only: it worked fine.

I then tested this with a card that had 2 checklists: it worked just as fine.

 

I had a slow motion look at your video and looked really carefully at the card names. But I couldn't spot any mistakes made from your side. However, and that's nothing but an assumption here, but I have the feeling your card's name is something that Butler might find confusing. Maybe the brackets are a problem.

If you have a dummy card anyway, can you try and reference back to this dummy card for the checklist - and see if that works?

As I said, it works for me. So generally it is working.

The only other reason I could imagine causing this, is you have run out of operations for this month. Are you a free Butler user or do you have some paid plan?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Trello

Develop a new Habit during Lockdown

If you had to thrive a new habit during a lockdown, what would it be? Trello

1,661 views 16 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you