Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Butler Rule not working to link cards that a butler board button creates

I made a board button that Creates 2 cards (one new card and one is a copy of another card on the board) that I need to complete a Purchase Order process.

What I need to happen next is have the 2 new cards linked together and then have one of those cards moved to another board.

I made a rule that seems like it should do that, but nothing is happening when I create those 2 new cards, even though that is set as the trigger.

Please let me know how I can fix this, or if there is a better way to get the two cards linked with one on a different board. I have tried a couple slightly different ways but each time the rule doesn't do anything.

Button and rule shown in picture below:

Butler board button and rule.png

2 answers

1 accepted

0 votes
Answer accepted
Katrin Anger Community Leader Jul 04, 2019

@Evan Meinerts 

Hi Evan, from what I can see the two pictures show the board button only. Can you add another screenshot of the rule?

There is only one picture, you will have to scroll to the right to see the rule.

Katrin Anger Community Leader Jul 12, 2019

@Evan Meinerts 

Okay, let's move step by step.

I re-created the board button and I get it to work for the first part. The second creates a copy of an already existing card. Right?

So, I tested this. And it worked. Here's the command I set up:

Bildschirmfoto 2019-07-12 um 18.44.48.png

And this is the result I got:

 

Bildschirmfoto 2019-07-12 um 18.45.10.png

 

And this is what you wanted to accomplish, right?

 

So, comparing my Board Button with yours, I suspect that the icons you are using in your list name is something that Butler cannot deal with and doesn't recognize. -- Can you try and remove them and run your command again?

 

Let me know how it goes and I'll check back on the 2nd command.

Katrin Anger Community Leader Jul 12, 2019

@Evan Meinerts 

In regards to the 2nd command:

It appears to me that the trigger isn't well chosen.

Instead of "when a card (...) in list XYZ is added to the board" [=> which is a condition that makes not really much sense], I would try something like "when a card (...) is added to list XYZ"

The actions in this rule look pretty much okay. I would have chosen the same (except for any possible icons or emoticons in the list's name).

-- Can you try with a different trigger if the rule is working now?

@Katrin Anger 

After adjusting the trigger like you suggested, the rule now works!

I swear I looked at all the different trigger options and did not see that one before, but it makes perfect sense that the new trigger of 'when a card with XX name is copied to list XX' works.

To clarify, the board button had always worked just fine, It creates the two cards I need as expected. So butler can handle the different icons.

 

THANK YOU so much!!

Like Katrin Anger likes this
Katrin Anger Community Leader Jul 13, 2019

@Evan Meinerts

You are very welcome, Evan! I am glad it is working now and you can even keep the original list names :)

0 votes
Iain Dooley Community Leader Jul 04, 2019

@Evan Meinerts Butler can't react to actions that Butler itself takes so if you create a rule that links 2 cards together, and it's a Butler button that creates those cards, it won't trigger the rule.

So what you need to do is include all the actions you want to take in the original button.

I also created this framework for automating Trello with Google Apps Script that doesn't have the same limitation, so might be a better option in some cases where you need to "chain" commands together:

https://community.atlassian.com/t5/Marketplace-Apps-articles/Introducing-Trellinator-Automate-Trello-with-Google-Apps-Script/ba-p/925271

Katrin Anger Community Leader Jul 06, 2019

@Iain Dooley 

Actually, that's not correct.

The Butler Power-Up acts as the user, not as an external user. This means, that - contrary to the ButlerBot - it can react on its own actions.

Ok, if it can react to its own actions then I would be very interested to learn why my rule doesn't trigger the actions.

Katrin Anger Community Leader Jul 10, 2019

@Evan Meinerts 

Can you have a look into the command logs of both rules if there are any error messages showing up?

There weren't any errors other than one at the very beginning of the list for the Rule (It was because I had my board button create the card the rule was triggering off of before it copied the card that the rule was looking for, so the order was mixed up. I then switched the order around and there weren't any errors again, not for any of the different changes I made to the rule to try to get it to work.) 

I also ran the board button again and it still failed to do it and neither the button or the rule had any errors.

 

Is there a way for someone to take a look in my account to see if it can be figured out? This commenting back and forth seems like it could take quite a long time to resolve the issue and the delays between replys (mostly on my end) make it hard to remember what the issue is and requires re-researching every time.

Katrin Anger Community Leader Jul 12, 2019

Hi @Evan Meinerts 

This is a community forum and not the official Trello support, and we are doing our best to help you out (for free). I understand that time restrictions can be tough, but in such cases it might be better to ask a consultant to help you out.

Also, when you write a comment, it's a really good idea to tag us in the comment so that we know there has been a reply. Otherwise, these requests just end up in cyber space.

---

I have had another look at your commands and I think I know what the issue is.

There isn't anything executed, because Butler is looking for purchase orders "PO####" and there aren't any purchase orders with such a purchase number. Am I right that you are trying to use '####' as placeholders? If so, you should use wildcards {*} instead.

In the 1st board button, are you addressing the same purchase order in the two parts of the command?

@Katrin Anger 

Thank you for your help and clarifications - I really do appreciate your free help and did not mean to be rude, I just thought it would be easier for someone to help if they could poke around more instead of being limited by what I can describe. Also, I didn't realize that Trello staff were not the ones responding to these things. 

I have tried submitting a help request via the Trello Support and I can't even get my request to submit. I have tried multiple times and just cant get it to submit, the page just goes away but I don't get an email confirmation that they received it and no one has reached out to me about it yet.

------

You are right, we are using '####' as placeholders, but that is literally what I want the rule to trigger off of. When I click the board button to make these new cards, I don't know what the actual PO# will be, so I will modify the titles of those cards after I create the PO in my inventory system. But I want the cards to be created to literally say 'PO####', and therefore I want the rule to trigger off of that name. So yes, I am addressing the same purchase order in both parts of the board button, literally 'PO####".

This allows me to use the same board button for each PO I create and then I simply change the title of the card to the correct number when I have one generated by my inventory system.

And I will only have one set of cards being generated with 'PO####" at a time, because I will be changing the title shortly after so there won't be any issues with trying to relate more cards than intended. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Trello

📹 What is Trello?

Hello Community!  My name is Brittany Joiner and I am a Trello enthusiast and Atlassian Community Leader. I'll be sharing with you a series of videos with my top tips on how to best use Trello...

291 views 9 16
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you