Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,807
Community Members
 
Community Events
176
Community Groups

Are special permissions required to download file via trello API?

Edited

My objective is to download files attached to a card via the API. 

To do this, I am trying to follow the instructions given at:

Update: Authenticated Access to S3 - Trello / Trello Announcements - The Atlassian Developer Community

 

Here's what I'm trying:

curl -H "Authorization: OAuth oauth_consumer_key=\"MY-TRELLO-KEY\", oath_token=\"MY-TRELLO-TOKEN\"" https://trello.com/1/cards/CARD-ID/attachments/ATTACHMENT-ID/download/MY-FILE.png

 

I get back:

unauthorized permission requested

 

I know my KEY and TOKEN are correct -- I am able to use them for other trello API calls (as query parameters)

I think the URL is correct. I am able to cut-and-paste that into an authorized web browser and I get the file.  I have also tried changing the hostname from "trello.com" to "api.trello.com" as indicated in the instructions.  No help.

 

I am currently using the free version of trello.  There is a statement in the announcement that mentions Enterprise users:

Authorization for attachments will be turned on for individual enterprises on an enterprise-by-enterprise fashion.

But it wasn't clear to me if this was intended to indicate that this feature is limited to Enterprise users, or simply that if you are an Enterprise user it will be rolled out over time.

 

Any help on what I might be missing?

1 answer

@Roger Lipp 

Nothing special except for the correct api construct and valid api key and token. For that matter, anything that is has url https://trello.com will need permission.

Thanks @milynnus for looking at this.  Unfortunately, I'm still stumped.  

The examples seem to imply that the key and token used in the authorization header are the same as what is used as query parameters for other API access.  So that's what I've been doing.  Not 100% sure if that's right.  But it is definitely not working for me.

I have also tried https://api.trello.com and that gives the same result.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events