Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,297,449
Community Members
 
Community Events
165
Community Groups

While trying to update an existing story through import, Unexpected failure occurred.

Unexpected failure occurred. Importer will stop immediately. Data may be in an unstable state: At least one given IssueParentAssociations must not be empty!

 

1 answer

0 votes
Alex Koxaras Community Leader Jul 30, 2021

Hi @IG Solutions

What kind of fields are empty? The message states that "IssueParentAssociations must not be empty!". Do you have any kind of relationship among the issues you are trying to import?
Care to share more info? 

@Alex Koxaras 

I'm getting this problem as well.  Everything for the first record imports, but then get the error.  Even with a CSV that only has IssueKey, Summary.

this is Blocking me updating via CSV (more than 1 record at a time).  I have quite a few items to update.

 

here is the last line of the log

2021-08-02 19:38:17,783 ERROR - Unexpected failure occurred. Importer will stop immediately. Data may be in an unstable state: At least one given IssueParentAssociations must not be empty!

 

Alex Koxaras Community Leader Aug 03, 2021

Hi @Mark Anderson and @IG Solutions ,

The error you are facing when trying to import the issues to your Cloud application usually happens when: 

1 - You try to import sub-tasks before importing the related parent issues or

2 - You try to import the issues to a Next-gen project. For now, it is not supported yet (See JSWCLOUD-17758)

Additionally, please check if the CSV file is properly configured by following the steps in the documentation below:

How to prepare a database export for a CSV Import from a JIRA Server application to a JIRA Cloud application

The above is the official answer from Atlassian itself, as described in this question https://community.atlassian.com/t5/Jira-questions/Importing-to-JIRA-cloud-from-csv-exported-from-JIRA-server-fails/qaq-p/1180981

Regards,
Alex

Alex, thank you for getting back to me.

I do have a next-gen project, but had no problem importing hundreds of new issues.  The problem only happens when trying to Update.

I'm just living without it for now.  Be nice for it to work though.

thanks,

Mark

Alex Koxaras Community Leader Aug 03, 2021

Then try to look if you are updating an issue which has no parent. Most likely that will be the cause of your problem.

Just Story work items, they don't have parents.  I tried again and specified Type = Story and mapped it (I was relying on Jira to figure it out previously).  But still only imports 1 and stops with error.  

Alex Koxaras Community Leader Aug 03, 2021

And what kind on columns you are trying to import? What kind of data they have?

Do you include any epic link, or parent issue?

its all plain text, no links.  there aren't any parent issues for the work item type in question.    

I tried a new file to update a Bug, still gives same error.  CSV contents below.

IssueKey,Type,Summary
CAD3-3208,Bug,"Add a location phone number field to the EVA form"

Alex Koxaras Community Leader Aug 03, 2021

Can you delete all other lines below that line and try again?

I routinely open in notepad++ prior to importing to make sure there aren't any phantom rows or columns ;-)  And did so in this case.

Is there anymore detailed logging on the server side?

Also, I just confirmed that I could import that same line as a New Bug, I removed the first column and then imported it.

Alex Koxaras Community Leader Aug 04, 2021

Hi @Mark Anderson

I've tried importing (and updating) an issue on my instance, and despite of receiving the same message, my issue was successfully updated!

Can you confirm the same?

Alex

Yes one row will update despite the error.  But if you are importing multiple rows the process halts after the first item is updated.

Can you try with two or more items to update?

thanks 

Mark

@Alex Koxaras  

This seems like a defect to me.  Will you enter a bug for it?

thank you,

Mark

hi @Alex Koxaras 

I have same error when importing the data. I am using the classic project without any parent and child anyway. Here is the error I get :  

"Unexpected failure occurred. Importer will stop immediately. Data may be in an unstable state: At least one given IssueParentAssociations must not be empty!"

I just want to bulk edit labels, so I just map : Summary (as required one), Issue Key and Labels. 
Please advise. Thank you.

Kind Regards,
Moyo

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Team-managed projects

Find issues faster in your team-managed board and backlog

Hi Jira Community! I’m Mark, a product manager working on Jira Software. Today, I’m happy to announce that we’re launching custom filters for team-managed projects. If you’ve used the quick filters...

3,848 views 19 21
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you