windows 7 64bits ,Sourcetree openssh putty GIT PULL not working?

git -c diff.mnemonicprefix=false -c core.quotepath=false fetch origin
The server's host key is not cached in the registry. You
have no guarantee that the server is the computer you

think it is.
The server's rsa2 key fingerprint is:
ssh-rsa 2048 xxxxxxxxxxxxxxxxxxxxxxxxxx
If you trust this host, enter "y" to add the key to
PuTTY's cache and carry on connecting.
If you want to carry on connecting just once, without
adding the key to the cache, enter "n".
If you do not trust this host, press Return to abandon the
connection.

1 answer

This widget could not be displayed.

If you are confident you are connecting to the correct host, you need to intiate an SSH connection to that server from PuTTY directly, and PuTTY will give you the option to trust the fingerprint.

any chance you can provide a step by step guide please.

 

"C:\Program Files (x86)\Atlassian\SourceTree\tools\putty\plink.exe" -ssh user@github.com

Tried. Failed. How do you indicate the host?

In Henrik's comment, the host is github.com. If you are connecting to a different host, that is where it goes.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

878 views 2 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you