source tree ssh proxy

Running Source Tree on Windows, and so far the UI is great. I am running into a big problem though in that it does not use my proxy setting in ~/.ssh/config

Right now, I do the commit then go to the command line to push/pull. Any way I can get Sourcetree to play well with the proxy?

1 answer

1 accepted

2 votes
Accepted answer

SourceTree uses PuTTY rather than OpenSSH because it's a bit more Windows friendly, but does mean any custom config doesn't automatically come across.

If you need to customise settings, the easiest thing to do is download the full PuTTY.exe client from and launch it. Then:

  1. If you want to set this up globally for all servers, click 'Default Settings' and then 'Load'
  2. Go to Connection > Proxy
  3. Fill in the proxy details
  4. Go back to Session, and click 'Save'.

If you didn't want to set this for all servers, you could type an session name under 'Saved Sessions' and complete the host name above before saving, then you can use that session name instead of the server name to pick up those settings. This is equivalent to setting up aliases in OpenSSH.

Thanks, this is perfect. The only thing is in step 4, you have to click "default settings" before save...took me way to long to do that.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

1,110 views 4 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you