"ignore" is now missing

The right-click "ignore" menu item is missing in version 1.6.13 of the Windows client. Effectively, the only way to add items to the .gitignore file now is by hand editing it. This is not ok. Please bring it back.

 

5 answers

This widget could not be displayed.

Hi,

Unfortunately this is a regression introduced in 1.6.13, completely unintentional and a QA fail on my behalf.

https://jira.atlassian.com/browse/SRCTREEWIN-2949

Apologies for this. I'm currently working to get back for you.

The bug you linked to (https://jira.atlassian.com/browse/SRCTREEWIN-2949) is about adding files to the index. The question was about adding to .gitignore, is it the same bug? In any case, I have the same problem on 1.6.13, thanks for keeping us informed on this!

@Michael Minns thank you so much for fixing this in 1.6.14, this issue was driving me nuts!

This widget could not be displayed.

Works for me. Screenshot?

This widget could not be displayed.

sourcetree-missing-ignore.png

Weird. You can post a bug report to jira.atlassian.com.

This widget could not be displayed.

I have attached an image below.

This widget could not be displayed.

I have the same problem in 1.6.13. The ignore option is no longer in the contextual menu.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

885 views 2 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you