p4merge no longer launches after OS update

It was working in the past, but I'm not sure how long it's been since I needed to merge.  I recently updated Mac OS from 10.10.4 to 10.10.5.

I have the latest SourceTree and the latest p4merge.  I have p4merge set for both diff and merge in source tree prefs.  I've tried it both with p4merge running and not running when I select "launch external merge tool".  I have restarted both programs.  What else should I try?

As a work around, I manually set the base, #1, and #2 in p4merge, but it is a slow process, also error prone.

2 answers

Sounds like I'm having a similar problem w/ FileMerge aka opendiff - that won't open either when selecting 'External Diff'

I reverted back to an older version of p4merge and toggled the choice of merge tool in SourceTree prefs, and it's working again.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

647 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you