how to integrate gitlab to sourcetree?

I am trying to integrate our local gitlab repo to sourctree but I am not able to add remotes as gitlab host!!... I appreciate your help.

 

Thanks

Manoj

2 answers

You won't be able to "browse" to repos like that, that's not what Browse is designed for. Try just pasting the URL to your repo in the box when you are trying to clone a repository.

Thanks for update.

I tried to paste url to repo setting but could not find gitlab. I think gitlab and github is same. Not sure why it is not allowing me at all. I have posted question to stackoverflow with details. 

http://stackoverflow.com/questions/27570370/how-to-integrate-sourcetree-for-gitlab

When I tried to push anything from branch it always asked me password... and it never any password from my end.

 

That is OPTIONAL extended integration that is not avaiable for Gitlab. It is OPTIONAL. Choose unknown and move on.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

720 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you