can not clone from BitBucket with https

I can not clone from BitBucket to Sourcetree with https on MAC. 

After click on "clone" button on Sourcetree, I entered a login password of BitBucket on the "Password Required" modal screen (pop-up), then it displayed below message.

warning: connecting to bitbucket.org using legacy security technology (TLS 1.0); see https://mercurial-scm.org/wiki/SecureConnections for more info

abort: HTTP Error 404: Not Found

Sourcetree version 2.7(152)

Please advise me.

1 answer

I would suggest you to add the Bitbucket account in Sourcetree in the preference window. As part of this, please make sure Sourcetree has written to keychain. (You might want to remove the existing set of keychain items before you add the account). 

Then, navigate to the remote tab of Repository browser window. You should be able to see a list of all remote repositories you have access to and clone the repo from there.

Thanks!

Suggest an answer

Log in or Join to answer
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

274 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot