bit bucket link to clone new mercurial repository in source tree has problems

As this screencast demonstrates

http://screencast.com/t/7FmqAeXkLiH

when i try to clone a new mercurial repository using the link in bitbucket i get the following error message.

hg clone -b default https://kirsteng@bitbucket.org/kirsteng/mytest C:\Users\kirsten\Documents\mytest

abort: unknown branch 'default'!

Completed with errors, see above.

I can clone successfully using Source Tree itself.

2 answers

Me too, I've just started to try SourceTree and bumped into this error!  If I'm a total newbie, I'd turn away from SourceTree and/or Bitbucket as there's no way to know which one is the real culprit.

Same problem... 

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 11, 2018 in Sourcetree

Tip from the team: debugging Sourcetree

Supported Platforms macOS Windows If you're reading this and it's not just educational… we know you're unhappy right now and apologize for that   We're dedicated to improving yo...

668 views 9 6
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you