WinMerge returns "right path is invalid" error when launched from SourceTree

I'm using SourceTree for Windows and I've set WinMerge as my external diff tool. When I click on the "External Diff" button WinMerge launches with the left path set to the appropriate file and the right path is empty. A message at the bottom of the WinMerge windows indicates "Right path is invalid!". I've tried using the custom option with combinations of $LOCAL, $REMOTE, and $BASE with each combination returning the same error. How do I get WinMerge to work with SourceTree?

2 answers

I've been using WinMerge as diff tool without changing any settings, with a git repo. Are you using it for git, or mercurial?

I'm using it for GIT. I found a solution, I'll post it below.

Using Embedded Git fixed my issue. Go to Tools -> Options -> Git -> Click on "Use Embedded Git"

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

709 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you