Why wont sourcetree start after i upgraded to windows 10 creator Edited

I got upgraded to windows 10 creator today.

 

And sourcetree wont even start.

I tried uninstalling, reinstalling, deleting all folders I could find with atlassian and sourcetree (and that SquirrelTemp which the latest installer leaves lying around). Nothing

Not even anything in the sourcetre .log file

 

I even tried reverting to version 1.9. Not much success but at least I get a log file, where it contains loads of

ERROR [2017-05-13 15:31:28,324] [1] [SourceTree.Configuration.WpfSpellCheckerPreFlightCheck] [Run] - Removing non-existent dictionary reference [C:\Users\Dad\AppData\Local\Temp\2b52ng5f.dic]

But those files don't exist.

The windows event log is full of these:

Fault bucket 120740603425, type 4
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: SourceTree.exe
P2: 1.9.9.20
P3: 5840b248
P4: d3d9.dll
P5: 10.0.15063.0
P6: 631de416
P7: c0000005
P8: 000000000000fd0c
P9:
P10:

Attached files:
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERD8EE.tmp.dmp
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERDA37.tmp.WERInternalMetadata.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERDA4D.tmp.csv
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERDA5E.tmp.txt

These files may be available here:
C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_SourceTree.exe_56ddd1e342e8aeb4f610e5a786c164db27299ab_9e4a36bc_b08bdf56

Analysis symbol:
Rechecking for solution: 0
Report ID: ce10d8b6-8a28-47f1-bd26-3c3db67e0ae2
Report Status: 268435456
Hashed bucket: 15cb554480aac178fd5d912d5f740885

3 answers

1 accepted

Found out after another program crashed in d3d9.dll this was due to rivatuner statistics server not playing nicely with windows 10 creator. Updated that to latest beta and all is OK

0 votes
Maarten Cautreels Community Champion May 13, 2017

Hi Tom,

Did you take a look at this Knowledge Base Article. It may have a solution to your problem: SourceTree crashes on startup

Please let us know if it helps!

Best,

Maarten

Well, no. As per my questio, I deleted everything to do with atlassian (or at least moved it out of harms way) and did a clean install. And it still fails.

 

In any case, I checked the appropriate file and it is remarkably null free.

Maarten Cautreels Community Champion May 13, 2017

Hi Tom,

In that case I'm afraid you'll be best off contacting Atlassian Support about this issue.

Best,

Maarten

I ended up having to disable the display adapter:
'Intel(R) HD Graphics 530'

Not ideal, considering this handles external montors...

Looking forward to a fix asap.

Suggest an answer

Log in or Join to answer
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

231 views 0 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot