Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Why does Sourcetree keep prompting for username/password? Edited

Hello,

I've seen this issue mentioned a few times throughout the forums, but the solutions that I've found there do not seem to be working for me.

In short, I use Sourcetree all day long and make frequent commits. Each time I commit (or pull) the app prompts me for my username and password.

Can someone please advise?

Thanks!

-Bill

1 answer

0 votes
Mikael Sandberg Community Leader Sep 12, 2018

Hi Bill,

Welcome to the Atlassian Community.

When you get prompted for username and password, is it Git Credential Manager for Windows that is prompting it? If that is the case you can turn it off by running these two commands:

git config --system --unset credential.helper
git config --global --add core.askpass "" 

Yup, that seems to have done the trick.

Thanks so much for the lightning fast support!!

Sorry, scratch that. I restarted Sourcetree and hit the same problem. Ran the above commands in gitbash.

In answer to your original question yes it appears to be Git Credential Manager for Windows that is prompting me.

Thanks!

Here is a screenshot, just for the record:

 

Screenshot (2).png

OK, so after many abortive attempts to address the problem, I finally came across this little nugget about three quarters of the way toward the end of the Git Credential Manager help file (located on my machine here: C:/Users/[myusername/AppData/Local/Atlassian/SourceTree/git_extras/git-credential-manager.html):

 

Q: Why doesn’t SourceTree use the credentials in the GCM?

You need to configure SourceTree to use the version of Git installed for the entire system. By default, SourceTree uses a local copy of portable Git.

To fix this go to ‘Tools > Options > Git’ and click the ‘Use System Git’ button.

 

My button just said "System", not "Use System Git", but it did the trick, happy to report. Now if I could just have the 4 hours I spent digging for this back ... :/

Final note, and just to lend weight to the above solution, I had the exact same problem on my Mac (OS X), and the same solution did the trick. For what it's worth. Out...

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,274 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you