Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,298,063
Community Members
 
Community Events
165
Community Groups

Why The source tree redirects me to the localhost URL?

Edited

I have saw this bug several times during source tree installation. When the Source tree ask me to login with bitbucket and redirects me to the login page in the browser. After login the source tree redirects me to:

 http://localhost:34106/?state=authenticated&code=ZPHwBxSEsdNypFJ2Vs

 

Is it not error. I think the source tree developers have not updated this link while going from development into production.

 

 

Thanks

6 answers

For me the Error is:

This site can’t provide a secure connection
ERR_SSL_PROTOCOL_ERROR

My Solution: 

1. Open an incognito Window
2. Change HTTPS to HTTP
3. Refresh page and I'm authenticated

I'm on SourceTree version 3.3.8

I am seeing the same issue - redirected to localhost and nothing happens from there.
GJ Atlassian - also GJ with ignoring comments and tickets on this - moving on to another GUI.

Look at my "Solution" above this response. It worked for me.

Like 이범호 likes this

I have managed to login uninstalling actual version(SourceTreeSetup-3.1.3) and downloading version 2.1.11.0 (https://www.sourcetreeapp.com/download-archives). After login just update and that's all.

I have followed this approach and It worked.

Thanks

Thanks Sergio, it did it for me.

I was unable to login through the webpage cookie or whatever which was trying to connect to localhost:34196...big misshap from Sourcetree devs

Like 今井真 likes this

it works for me too

thank you

 

Thanks @Sergio . You saved my day :)

I found another question about this topic.

https://community.atlassian.com/t5/Sourcetree-questions/Installation-problem-localhost-34106/qaq-p/984572

ali kamsari mentioned it could be an issue with chrome as default browser. So I changed temporarily my default browser to Edge and it work for me.

Tried Firefox, Chrome and Edge (in that order), then thought perhaps it's not a browser issue so executed  netstat -ano | findstr "34106"  and there's nothing listening on that port.

Hey @Ana Retamal  and Atlassian team, *there's nothing listening on that port* so you definitely have a bug.

Perhaps the devs have a different local setup or the production build has a slightly different configuration or something, but whatever component is meant to be listening...isn't.

 

Steps to reproduce:
Download latest version (as of 3 August 2020) of SourceTree
Install
Try to connect account via OAuth

 

Log extract:
ERROR [2020-08-03 14:18:05,154] [1] [SourceTree.Exceptions.RemoteHostException] [Log] - Unable to receive callback from OAuth service provider
ERROR [2020-08-03 14:18:05,185] [1] [SourceTree.Exceptions.RemoteHostException] [Log] - Unable to get user secret
ERROR [2020-08-03 14:18:05,186] [1] [SourceTree.Exceptions.RemoteHostException] [Log] - Unable to get secret

 

Edit:
Found that even when uninstalling SourceTree, it leaves loads of garbage behind in your AppData folder.

Resolution:
Uninstall Sourcetree
Delete the following folders:
  C:\Users\{your username here}\AppData\Local\Atlassian
  C:\Users\{your username here}\AppData\Local\SourceTree
  C:\Users\{your username here}\AppData\Local\SquirrelTemp
Reboot (unsure if this helped or not but I rebooted so adding the step)
Reinstall SourceTree

Conclusion:
Atlassian needs to clean up their uninstall process.
This is likely a scenario that new users won't experience, but more specific to existing users upgrading to newer versions of SourceTree as was my case.

I've just lost a day trying to fix this. Oauth is redirecting to an empty localhost page and then nothing happens in source tree.

And for no apparent reason, it starts working again. I don't even get the satisfaction of knowing what I did to fix it.

Yes issue still exist in version 3.3.8. 

I'm facing the same issue. Got a new notebook to set up.

I cannot install Bitbucket at all. I tried several versions (3.3.8, 3.3.6, 2.6.10 and 2.1.11.0) at the latest when updating to a newer version it all ends up in the above mentioned error.

 

I'm not able to use Bitbucket at the moment what is a very big problem...

Like Prabhu Mani likes this
0 votes
Ana Retamal Atlassian Team Jan 08, 2019

Hi, welcome to the Community!

I've asked the developers about this, and they replied that this is intended. That link is the callback used during OAuth flows, Sourcetree runs a local server to capture the OAuth tokens.

Hope that answers your question!

Ana

But there is no local server running on my system, and the installation cannot proceed. Everytime I click on grant, nothing happens. This is definitely a bug.

Like # people like this

I´m in the same situation... :(

What to do ???

 

Thanks!!

Like # people like this

I seems very paltry that a that such a highly technical team would produce such a naive coding blunder.

Disappointed through out. 

Like # people like this

This bug is happening for me too. I get this error:

Invalid redirect_uri

This integration is misconfigured. Contact the vendor for assistance.

There is some problem with that local server, i have created several accounts but after succesful login in my browser it's still waiting for login.

Almost a year has passed and this problem is still there! 

I cannot install latest version

Like Prabhu Mani likes this

Source tree Version 3.3.8 and problem still exist.

I'm not even using sourcetree, just trying to use the visual studio built in git support and it does this same thing to me... in 2022.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Bug Fix: Sourcetree for Windows authentication error when updating to app password

Hello Sourcetree users!!! With the recent removal of Bitbucket Cloud account passwords for app passwords (please see our Bitbucket Cloud community post for details on why we made this change for se...

61,842 views 127 27
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you