Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Where is the user manual for Sourcetree?

Attempting to use Sourcetree for the first time. I am not able to find a user manual. There is no Help available onscreen. 

As part of the setup I need to login to the bitbucket server.  It asks for a URL but does not provide any specification or example. I have gone to my local bitbucket server and used the Clone function to obtain the URL of the repository.  It has the form http:// USER @ Server IP address/Project/repository 

When I try to use this in Sourcetree it gives the error  - Invalid URL:The hostname could not be parsed. 

What format is it looking for if not the format produced by Bitbucket? 

 

3 answers

0 votes
Mikael Sandberg Community Leader Aug 02, 2018

Hi Tom,

Welcome to the Atlassian Community.

You can find the user manual here, Get started with SourcetreeThe root URL is the same URL you use to access Bitbucket from a web browser, for example http://bitbucket.mycompany.com:7990

I have reviewed the - Get started with Sourcetree - manual. However, the manual does not have any information regarding the "Login to Bitbucket Server" screen  The screens shown in the manual do not correspond to the screens shown in Sourcetree 2.6.10.0 

I have tried logging in using:

  • http://IP address of server/project_name  at the root of the repository tree
  • http://IP address of server/project_name/specific_repository_name
  • http://IP address of server/project_name/specific_repository_name:7990
  • http://IP address of server:7990
  • http://IP address of server

 In every case Sourcetree returns the error - Invalid URI: The hostname could not be parsed. 

Any tips on how to debug this?  This is turning into a huge waste of time. 

Mikael Sandberg Community Leader Aug 07, 2018

Have you tried just entering the URL into a web browser to make sure you can reach Bitbucket? Also, do you use an email address as your user name?

I can access and traverse the repository via my web browser with no problems. Works great. 

I am using my email address to log in. Sourcetree does not give any indication of an authentication error. 

When I copy the URI from my browser into Sourcetree, do I need to modify the URI in any way? 

Could it be that the corporate firewall is blocking access to the particular port?  i.e. does the web browser access the repository on a different port than Sourcetree?  When I did a netstat I see that my machine has Established a connection to <server IP address>:http.  I do not see any other connections (ports) to the bitbucket server. 

Any suggestions?

Mikael Sandberg Community Leader Aug 07, 2018

Okay, so it is the @ in your email address that is causing it. I discovered it a couple of months ago when we switched to use our email addresses as user names in order to prepare for a AD migration. Here is the bug I logged for it, SRCTREEWIN-8648.

Thank you for the explanation. This was very helpful.

It looks like Sourcetree is not usable in my environment.  I will just go back to using my web browser. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,378 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you