Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

What happened to Windows 2.6.3? Edited

I was on Sourcetree 2.6.3 Windows and LFS downloads were incredibly slow. Updating the embedded git would not take me past LFS 2.0.2. I tried re-downloading Sourcetree and installing, but it rolled me back to 2.5.5 and downgraded the embedded git from 2.17 to 2.16, but with LFS still at 2.0.2. I did a complete uninstall of Sourcetree and wiped everything in AppData. I also took the extra step of removing every version of git from my computer and any other source control software that I had.

I re-downloaded a new installer and am now at 2.5.5.0 with embedded git 2.16 but now I have LFS 2.3.4.

A co-worker was lucky enough to get a good update to Windows 2.6.3 with embedded git 2.17 and LFS 2.4. His LFS downloads are MUCH faster than everyone on the team.

Why can I no longer update back to 2.6.3? Why is 2.5.5 the only version offered on the website now?

------------------------------

Update: there is a manual download link for 2.6.3 https://downloads.atlassian.com/software/sourcetree/windows/ga/SourceTreeSetup-2.6.3.exe

1 answer

1 accepted

1 vote
Answer accepted
Mikael Sandberg Community Leader May 30, 2018

2.5.5 is still being rolled out, Sourcetree moved to staged updates about a year and a half ago, have a look at this blog post about it. Only once the staged roll out reaches 100% will it be available to download from the website.

Mikael Sandberg Community Leader May 30, 2018

You can always download and install Git separately instead of using the embedded version. I have been running Git 2.17 for a while now with Sourcetree 2.5.5 without any issues.

Thanks for the reply. I tried using system git 2.17 and LFS 2.4 but then sourcetree started giving me password errors. Even when I removed and re-added all user accounts, it wouldn't let me touch my repos on bitbucket. Switching back to embedded fixed this. I could give it another shot with this fresh install.

Mikael Sandberg Community Leader May 30, 2018

The password errors could be from the Git Credential Manager for Windows, we have had issues with it and I always recommend not to install it, but it is not always that my developers follows my instructions...

I installed git with the credential manager disabled (thanks for the tip). Though it still doesn't want to play nice with sourcetree. This time instead of being a password issue, it's a two-factor issue (which is not a problem with embedded).

remote: Two-step verification is enabled for this account.
remote: We recommend using SSH when two-step verification is enabled: https://confluence.atlassian.com/x/zYoMEg
remote: To proceed with HTTPS, you must use an app password to authenticate: https://confluence.atlassian.com/x/9DJmMQ
fatal: unable to access '(Removed before posting)': The requested URL returned error: 403

I've used SSH in the past but was advised by Atlassian to use OAuth instead for performance reasons with LFS. I'm not sure why this error message is asking me to make an app password.

Any ideas why system/embedded would behave differently?

Mikael Sandberg Community Leader May 30, 2018

I am wondering if the embedded version is getting the app password from Sourcetree. You could try and generate a new app password and change your repository URL to this: https://[your_user_name]:[app_password]@bitbucket.org/[your_user_name]/[repo_name].git

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,250 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you