Version 1.8 for Windows Mercurial not work

I cant select mercurial version from 3 provided ways. 

  1. Download but popup not hide
  2. Browse to location but popup not hide
  3. Check again but popup not hide
  4. I dont want to use Mercurial popup hide

And i want to use mercurial! 

 

3 answers

I just came across this issue as well, although the first time I could point it to Mercurial but it just popped up again, then further attempts it does not allow me to browse, it would start an embedded download though but I'd rather use the system one.

That's when I realised apparently it doesn't accept the latest mercurial version (3.7.1 at time of this post), you need to install 3.2.3 and then it's happy (3.2.3 is the version it also downloads and runs embedded).

On the Mercurial page, just copy the download link and change the version from 3.7.1 to 3.2.3 to download the version you need to use with SourceTree.

I have the same issue and tried your solution but does not work for me.

Hmm.. well I did give up on doing it at the time of the installer, I selected not to use Mercurial, then in the SourceTree GUI, under Options I tried enabling Mercurial support several times and it only stopped with that 4 option popup after installing Mercurial 3.2.3 specifically, it wouldn't accept 3.7.1.

I also used the x86 (32bit) MSI installer for both (extract it from the SourceTree.exe providing you have .NET 4 already installed), and I used this link (I changed the version from the current to the one the embedded Mercurial downloads 3.2.3) if you use the link and just remove the file on the end, you can see a directory listing of all versions, both MSI and EXE, http://mercurial.selenic.com/release/windows/

I also installed GIT using it's EXE installer with silent option before Mercurial and SourceTree and ST recognised that fine.

Thanks! But this not work. I tried Mercurial 2.3.2 (64 and 32) and latest 64 and 32. Now downgrade for SourceTree 1.7.0. 1.8.x is very bug trash version. They broken my favorite SourceTree smile

Windows 10 x64, SourceTree 1.8.2.2 - same problem persist. Can't use Mercurial =(

New SourceTree 1.8.2.3 - problem solved!

Devs, thank you.

Thanks!

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Brian Ganninger
Published Jan 23, 2018 in Sourcetree

Tip from the team: workflow and keyboard shortcuts

Supported Platforms macOS Sourcetree has a lot to offer and, like many developer tools, finding and using it all can be a challenge, especially for a new user. Everyone might not love ...

649 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you