It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Users unable to see Remote Repos (windows 10 - ST 2.4.8)

On windows 10 machines and on Server 2016 machine, source tree is not displaying remote repo's for users.  We do not use windows 7 so i can not test.  

We have upgraded some to version 2.5.5 but still zero luck.  Is this a common issue for other users?  Is this a common source tree issue?

We are using bitbucket.org to host our repos with two-factor verification enabled and the users ssh key is there and two factor is enabled in their profile.  They are apart of our team and are definitely apart of multiple groups that have repo access.   The users can see the repo's via bitbucket.org but no clue why source tree decides to not display anything.  

We can make the users admins but it doesn't matter, nothing shows in the remote repo section for these users when using ST.

 

 

1 answer

1 accepted

0 votes
Answer accepted
Mike Corsaro Atlassian Team Apr 30, 2018

Hello! Is there a red circle on the account in the remote view? If the user is still not able to see the remote repo, they can work around the issue by navigating to the repo on Bitbucket, and then using the "clone in Sourcetree" button.

Thanks @Mike Corsaro for the response.  We have validated the users has a refreshed oAuth Token, and when trying to directly clone from the SSH url, it is never able to locate the repo.  Just spins for minutes and we also validated that GIT is installed specifically for Source Tree and enabled. We dont use mercurial so we skipped that  installation.  I did validate that if i remove this user from all groups he was currently in and put them in the Admin group, then they can see the repos.

The setup that doesnt work for this specific user:

  • private project
  • private repo
  • write access to all repo's within the project

This resulted in nothing appearing in Source Tree for this specific user. Other users with the exact same setup (Group access, windows 10 machine, same ST version etc) would see the repo's.

The setup that worked

  • Admin on all repos in the projects

This resulted in him seeing the repos, but i cant have him in the Admin group.  

Mike Corsaro Atlassian Team Apr 30, 2018

Ah, okay. I suspect it's related to a bug we have on our end regarding remotes not being listed for a group unless that user has the "create repos" permission.

Ahh yeah, that is exactly it.  I just tested adding create repo permissions and that got them showing.  Im now following the JIRA bug.  Thanks @Mike Corsaro for bringing that to my attention! 

https://jira.atlassian.com/browse/SRCTREEWIN-7906?jql=text%20~%20%22remote%20repos%22 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,955 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you