Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Unable to install tool

I had source tree for windows before. After I requested for update(postponed for approx 6 months) it failed. Uninstalled, and can't reinstall and be getting 2 unable to install tool error messages:

1) Extraction of c:\users\myself\AppData\Local\Atlassian\SourceTree\gcmw.zip failed

2) Extraction of c:\users\myself\AppData\Local\Atlassian\SourceTree\mcmw.zip failed

 

Please advice

3 answers

0 votes
Nir Haimov Community Leader Mar 12, 2018

let me understand.

You are trying to install source tree on your windows pc and get the error?

Did you try to delete the "c:\users\myself\AppData\Local\Atlassian\SourceTree" directory and install again?

I sure did...

I have also rebooted PC, just in case...

Windows 8.1 if it matters.

what source tree version are you trying?

Nir Haimov Community Leader Mar 12, 2018

did you try to "right click" the installation and run as administrator?

Please ignore.

Nir Haimov Community Leader Mar 12, 2018

try to go to "c:\users\myself\AppData\Local\Atlassian\SourceTree\"

and extract manually both zip files.

That should work

Read this advice online. To extract where? Why should I do that? Isn't it an ST bug?

it's a bug, yes.

But we are trying to workaround it :)

in the  "c:\users\myself\AppData\Local\Atlassian\SourceTree\"

if you don't have it already, create new folder "git_extras", extract "gcmw.zip" to that folder.

if you don't have it already, create new folder "hg_extras", extract "mcmw.zip" to that folder.

OK. Will try it tonight.

Thanks.

А dank

Nir Haimov Community Leader Mar 15, 2018

@BRB 

Did it worked?

Nir, 

Those folders have existed, but *.exe files were not extracted from *.zip files. I did extract them manually. This process leaves a pretty bad taste in my mouth. 

Can I connect with you via LinkedIn?

Thanks.


7-Zip [32] 16.02 : Copyright (c) 1999-2016 Igor Pavlov : 2016-05-21

Scanning the drive for archives:
1 file, 610535 bytes (597 KiB)

Extracting archive: C:\Users\myself\AppData\Local\Atlassian\SourceTree\gcmw.zip
--
Path = C:\Users\mich\AppData\Local\Atlassian\SourceTree\gcmw.zip
Type = zip
Physical Size = 610535


Sub items Errors: 1

Archives with Errors: 1

Sub items Errors: 1

Nir Haimov Community Leader Mar 28, 2018

Hi,

Sorry for not responding.

Honestly, i have no more ideas.

Truly, i never faced the problem my-self, i install it with no problems, but i tried to help in every way i could have think.

I got no more ideas :(

@Nir Haimov

Appreciating your effort. Thank you anyway. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,333 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you