TortoiseGitMerge doesn't open for non-administrator account

I installed latest versions of SourceTree (1.9.6.1) and TortoiseGit (2.2.0.0). Now when trying to resolve merge conflict using external tool, small window flashes quickly and TortoiseGitMerge window doesn't open. If I run SourceTree as administrator - everything works as expected (SourceTree settings and .gitconfig are identical in both cases). Is it possible to have it working for non-administrator account?

Update: I reinstalled old versions of TortoiseGit and SourceTree, and nothing changed, I still can launch TortoiseMerge as external merge tool only when I run SourceTree as administrator.

2 answers

At the surface, it sounds like a problem with TortoiseGitMerge rather than SourceTree.

@Seth I reinstalled my previous version of TortoiseGit - 1.8.15.0-64bit, didn't help. Then I reinstalled my old version of SourceTree - 1.6.18, didn't help either. So looks like issue isn't related to versions. Then I tried to run SourceTree as administrator - still works just like before. 

The question still holds - how to be able to merge without running SourceTree as administrator.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

840 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you