It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

The "Remote" button goes to the first remote in the list instead of the default

When I click on the "Remote" button, it always goes to the first remote listed in the "Remote Settings" .

It does not go to the remote marked as default remote (or even origin).

I tried removing and re-adding remotes to change the order but that didn't work. It looks like the order of remotes is alphabetical.

I fixed the problem by removing remotes with names other than the default remote (which is origin in my case) and then re-adding them with their names prefixed with "z-" to ensure that they are not first. It's stupid, but it worked.

Note: I tried just renaming the remotes, but that didn't change the order. I had to remove and re-add with the new name.

 

Does anyone have a better solution than prefixing the the remote names with "z-"?

1 answer

1 accepted

0 votes
Answer accepted
minnsey Atlassian Team Nov 02, 2018

Hi

This sounds like a bug, can you raise it at https://jira.atlassian.com, thanks

bgannin Atlassian Team Nov 02, 2018

SRCTREE for Mac, SRCTREEWIN for Windows

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,955 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you