Terminal error "Failed to fork child process" unless run as administrator

From Windows 10, whenever I launch Terminal, I get an error that says, "Failed to fork child process: No such file or directory."  The title bar of this window is "/usr/bin/bash --login -i".  This occurs whether I'm set to use System Git or Embedded Git and I've tried updating Embedded Git as well as uninstalling/reinstalling SourceTree.

I did discover that if I launch SourceTree as Administrator (and accept the UAC prompt), I am able to launch into Terminal using either System Git or Embedded Git.

Has anyone seen this behavior or know of a way to resolve it?

Update: I discovered the mintty.exe and bash.exe in the %LOCALAPPDATA%\Atlassian\SourceTree\git_local\usr\bin\ folder.  If I run bash.exe directly from here it launches without an issue. 

Further update:
I found this appears to be an issue with cygwin that was recently solved in an update.  Does anyone know if there is a good way to update this independently for SourceTree?
https://cygwin.com/ml/cygwin/2016-08/msg00346.html 

Sorry - I don't have permissions to add Answers, but this doesn't appear to be a SourceTree issue, but more broadly a Git for Windows issue.  I have opened this issue here: https://github.com/git-for-windows/git/issues/898 

1 answer

I am using Windows 7 and still getting the same issue when i am trying to launch the terminal from sorce tree UI.

Using 64Bit system. 

Tried installing  Git in my system as well and getiing the same error. When i try to run mintty.exe getting the stack dump file generated.

Even running source tree as admin doesnot help.

Can anyone please help.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Oct 23, 2018 in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

715 views 3 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you