Stuck on Sourcetree version 0.9.1.1

Hi, hopeing you guys can help. My Sourcetree doesnt want to upgrade from 0.9.1.1. When I go to "Check for updates" the popup window insists 0.9.1.1 is the latest with a big green tick box even though under the "Latest Available" there is version 0.9.2

Any way I can install the latest (very keen on the gitflow improvements)? I have tried uninstalling/reinstalling/cleaning up clickonce folders all to no avail.

3 answers

1 accepted

This widget could not be displayed.

So I have downloaded and installed the new link from the latest offline installer from https://answers.atlassian.com/questions/149591/is-there-an-offline-installer-for-windows-version-of-sourcetree and now I am good to go. didnt quite solve the original issue, but at least I can check out the git flow stuff now. Thanks!

Glad you have it working. Very rarely it's possible for the ClickOnce database to get screwed up somehow and you have to manually clear everything out, this might have been what happened in your case.

I'm investigating alternative install / upgrade tools for the future because ClickOnce is causing too many random issues, so hopefully this will be a thing of the past soon.

This widget could not be displayed.

This usually happens if you've had to use the 'Repair' option at some point because of an update problem. If you uninstall SourceTree from Control Panel > Software and re-install it from sourcetreeapp.com, it should sort this out. You won't lose your bookmarks or open tabs etc by doing this, but options will be reset to the default again.

This widget could not be displayed.

Thanks for the reply Steve. Yeah have tried that. No luck for me unfortunately.

Weird thing is that the exact same problem is happening with another colleage on mine. But another colleage it is fine (there are 3 of us, 2 having this exact issue, 1 not).

Any other suggestion?

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

733 views 1 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you