Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,365,184
Community Members
 
Community Events
168
Community Groups

Stop Bitbuket's "Checkout in Sourcetree" option from attempting to use SSL instead of HTTPS

Edited

I don't have an SSL key in bitbucket and do not want to use SSH for anything related to it and source tree.

 

My settings in source tree are set to prefer HTTPS:

 

Untitled.png

 

But every time I try to use the Checkout in Sourcetree feature in bitbucket via:

Untitled3.png

I'm bombarded by the first of these popups, and after dismissing it with a no the second.

 

Untitled2.png

2 answers

Did you ever resolve this? I'm having the same issue.

As I commented above, it spontaneously went away for me.  I didn't do anything so have no more idea why it stopped than why it started.

0 votes
Mike Corsaro Atlassian Team Apr 02, 2018

Hello! When cloning from Bitbucket, make sure you set the option to use HTTPS rather than SSH, which should prevent that from happening.

bitbucket_https.png

It's spontaneously stopped this morning, but the page where I'm encountering it on doesn't have an SSH/HTTPS switch.

(see edit to original question)

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events