Sourcetree wont login (2.1.10)

Ever since updating to 2.1.10 I keep getting a prompt to login to bitbucket. For a while if I changed the preferred protocol to SSH and refreshed the OAuth token it would work for a bit, then later I would get the popup again, and I would switch back to HTTPS... Now neither work. I can't push so it makes sourcetree pretty useless. Any fix for this coming?

2 answers

0 votes

Hi Aaron,  SourceTree for Windows now shares credentials with Git via the Git Credential Manager (GCM).The credentials for both are stored in the Windows Vault or Credentials Manager, the entries are prefixed with 'git:' To determine what is going on I would:

  1. Remove all existing 'git:' prefixed entries from the Windows Vault.
  2. Remove any credentials from git config files.
  3. Disable the automatic remote checking of repositories in SourceTree. Then restart SourceTree and open each repository in turn and do a fetch. This should trigger the GCM to request credentials. Entering them there shoud mean they are stored correctly. 

Did this work for you? If you're still getting prompted for a password, let us know if you're getting any error when you try to push. Also, let us know if the URL is of the form https://bitbucket.org/owner/repo or https://user@bitbucket.org/owner/repo and make sure that Tools > Options > Authentication is hosting the right password.

Best regards,

Ana

I have been trying for a week now and tried all these methods with the new Sourcetree 2.1.10. Everything was working good until the upgrade last week and nothing is working anymore. None of the steps above help at all. And I can't seem to downgrade. This is annoying!! I'm able to push and pull using command line but not SourceTree. 

My URL for Bitbucket server is: https://tpg.spd.analog.com/bitbucket/scm/tok/arm.git

Please help asap because we're in the middle of a critical release. Thanks.

Ana, I've removed the credentials from the windows credentials manager and it still isn't working correctly. The login window keeps popping up everytime I try to push and I can't enter my password because I login with Google. Sometimes everything works as expected but later on in the day I'll randomly get promted for my login and wont be able to continue after that until it decides to start working again.

For what its worth, I'm running 2.1.11 now...

 

Also, the url is in this format: https://user@bitbucket.org/owner/repo 

I downgraded to the version 2.0.20.1

That's what I had to do to get it working as well. Downgraded to 2.0.20.1. Works now. Should we put in an Atlassian ticket or does it already exist?

I don't know... Maybe they don't know. 

SourceTree had an update and they didn't do anything to solve.

I just turn the updates off.. And I just use 2.0.20.1 version

I have the same problem. I had to revert to an older version 

Just check

https://www.sourcetreeapp.com/update/windows/ga/ReleaseNotes_2.1.10.html

Suggest an answer

Log in or Sign up to answer
Community showcase
Published May 30, 2018 in Sourcetree

Tip from the team: configuring Git or Mercurial in Sourcetree

Supported Platforms macOS Windows To make using Sourcetree as simple yet powerful as possible we embed (bundle) dependencies such as Git, Git LFS, and Mercurial. We strive to keep these...

989 views 2 3
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you