Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Sourcetree since version 2.5.5 paginates remote repositories starting with 1 and not 0 like before Edited

Why Sourcetree Windows since version 2.5.5 paginates remote repositories starting with 1 and not 0 like before?

With Bitbucket Server this is a problem because the first repository of the project is not retrieved. So if you have only one repository in your projects, in Remote repositories tab, not repositories are shown.

Now when you go to Remote repositories tab to clone a repository and select an account, Sourcetree sends this REST request for every project

GET http://xxx:7990/rest/api/1.0/projects/ENCPOPUP/repos?limit=30&start=1

With SourceTree 2.4.8 the request was:

GET http://xxx:7990/rest/api/1.0/projects/ENCPOPUP/repos?limit=1000&start=0

The response for the first request is 0 repositories (incorrect), the response for the second one is 1 repository(correct).

I suppose the problem in Sourcetree 2.5.5 is this change: Paginated remote repositories [performance and UX boost]

But why starting with 1?

There is any configuration that I can change in Sourcetree to make this request start with 0?

1 answer

1 vote
Mike Corsaro Atlassian Team Jun 20, 2018

Hello! This is a bug -- but if you're looking for a specific repository the search function should return the correct results. Thanks for finding it!

Which version will fix this bug? Thanks

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,293 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you