It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Sourcetree on MacOs crashes on launch if there is a local repo

I am on a MacOS with High Sierra 10.13.4.  This morning, when prompted, I updated to the latest version of Sourcetree, and since doing so I cannot get the application to stay open as long as it has a bookmark to a local repository.  As soon as the application launches, it crashes.

I have tried MANY different things, including:

  • Completely removing and reinstalling the latest version of the application (2.7.3), including the following steps:
    • Deleting the .app file from my Applications
    • Running 

      defaults delete com.torusknot.SourceTreeNotMAS in terminal

    • Deleting ~/Library/Application Support/SourceTree
    • Deleting ~/Library/Preferences/com.torusknot*
    • Downloading the latest version of the app and installing it fresh
  • Installing older versions of Sourcetree in the same manner (I've tried 2.7.2, and 2.7.1)
  • Rebooting my machine
  • Clearing my Mac's PRAM upon reboot

In each case, I can get through the initial setup of the application, but as soon as a local copy of a repository exists, the application starts its crash loop and can never recover unless I break the link to the local repository.

For example, if I do a fresh install and then clone a repository from bitbucket, the clone will complete, but as soon as it does, Sourcetree will crash.  Alternatively, I can do a fresh install, and then try to add a reference to a repository I have saved locally.  It will add the local repo, and then immediately crash.

In both cases, if I rename the directory where my local repository lives (thereby breaking the link between Sourcetree and the repo) and then restart Sourcetree, the application will start successfully and show me that it now has a bookmark to a missing local repository.

In the interest of brevity I won't paste the full crash report, but here is the beginning of a sample of one.  Any advice would be welcomed.

----

Process: Sourcetree [15779]
Path: /Applications/Sourcetree.app/Contents/MacOS/Sourcetree
Identifier: com.torusknot.SourceTreeNotMAS
Version: 2.7.3 (169)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Sourcetree [15779]
User ID: 501

Date/Time: 2018-06-06 13:55:22.623 -0500
OS Version: Mac OS X 10.13.4 (17E202)
Report Version: 12
Bridge OS Version: 3.0 (14Y664)
Anonymous UUID: 21498898-436E-FAB5-E83A-6AF1E7CD479C

Sleep/Wake UUID: 6A2B8221-DBC8-4030-8AC2-8B720365931E

Time Awake Since Boot: 17000 seconds
Time Since Wake: 6600 seconds

System Integrity Protection: enabled

Crashed Thread: 9 Dispatch queue: com.apple.root.default-qos

Exception Type: EXC_BAD_INSTRUCTION (SIGILL)
Exception Codes: 0x0000000000000001, 0x0000000000000000
Exception Note: EXC_CORPSE_NOTIFY

Termination Signal: Illegal instruction: 4
Termination Reason: Namespace SIGNAL, Code 0x4
Terminating Process: exc handler [0]

 

1 answer

0 votes
Ana Retamal Atlassian Team Jun 07, 2018

Hi Kirk! Seems like you're affected by a recent issue, please refer to this thread. From one of our developers:

We are investigating the crash with https://jira.atlassian.com/browse/SRCTREE-5762. There seems to be an issue loading and reading repo avatars. We will soon have an update on this. 

Please feel free to remove the ImageCache folder under ~/Library/Application Support/SourceTree/ for now. We are investigating this crash and will have an update soon.

Thanks for your patience! 

My recommendation would be to watch that bug ticket to be notified of further updates.

Best regards!

Ana

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,927 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you