Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Sourcetree keeps losing my bookmarks

For quite some time now, my bookmarks have been set in stone in sourcetree. If I delete bookmarks or add new ones, they seem fine for the duration of the session, but if I close and re-open sourcetree, the deleted bookmarks return and the new bookmarks are lost. This does not affect any of the underlying repositories, but I find it to be very annoying.

2 answers

Check if the folders used by SourceTree are writable by the user running the program. What you describe above indicates that SourceTree cannot save the bookmarks to disk.

I assume that is the folder where sourcetree is installed or one of the subfolders. In that case then no, the user does not have permission to write to that folder. Can I tell it to save the bookmarks somewhere else or how can I resolve this?

I think the only thing you can do is to install it to another place where it will be able to modify the files.

I uninstalled sourcetree and re-installed it to a new location, but it still has the same bookmarks and the problem persists. Where are these bookmarks stored?

There is a folder with stuff at c:\Users\<user>\AppData\Local\Atlassian . Probably somewhere here.

So guess there is no way to change which directory it uses?

Not sure, there might be a registry key for this... (I do not work for Atlassian, just use the software.)

Well...I deleted the c:\Users\<user>\AppData\Local\Atlassian\SourceTree folder, reinstalled...and it worked! :) just letting you know. The bookmarks issue was gone afterwards.

This was in version 1.6.13.0 by the way


Balazs Szakmary Thank. After changing the permission on Atlassian the issue is resolved.

I had the same issue. it worked after changing the Readonly access in the folders where sourcetree was installed as well as in the local data.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

5,304 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you