It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Sourcetree freezes on Win 7 when moving between applications

I have problem with Sourcetree on Windows 7 laptop, just updated the SourceTree from 2.3.1.0 where it was working fine to 2.4.8.0. It now freezes every time I move between applications.

 

I've looked for help and some suggested to make sure under Tools > Options > Git it uses 'Use embed Git' which it does and I've also updated Embedded Git.

Please advise what I can do as its gotten very annoying and very time consuming when its happening to 10 developers throughout the day every day.

 

Thank you.

2 answers

0 votes
minnsey Atlassian Team Apr 16, 2018

Hi

Sourcetree will refresh its UI when it comes back in focus, to ensure the UI correctly reflects the filesystem of the currently visible repository. It has always done this, so its not immediately obvious why this is effecting you now.

However can you try turning off the UI refresh behaviour in Tools/Options/General tab by unchecking the following options:

* Refresh automatically when files change
* Refresh when application is not in focus

You will then need to make use of F5 to force the UI to refresh.

If these do not improve the situation you can check what process are running and the time they are taking by opening the Tools/Process Viewer... dialog.

Is the performance hit the same across all your repositories?

Hi,

 

Sorry for the late reply.

I've done what you have suggested but still no joy.

The issue doesn't occur when I'm in Souretree. When I'm in Sourcetree it works fine when moving between repository tabs, creating feature branches etc. The issue happens when moving between different applications.

For example if I have Sourcetree and notepad open, if I Alt+Tab between the two application or if I click on the notepad icon in my tray and then click on Sourcetree, Sourcetree freeze for over 20 seconds and the top of the application it shows (Sourcetree not responding see attachment).  

This happens regardless of having one or none tabs open in Sourcetree. I've now updated my Sourcetree to latest version 2.5.5.0 and still experiencing the same issue

 

Im running Win 7 Prof SP1 64bit 8GB ram

2018-04-20 10_37_42-Sourcetree (Not Responding).png

Hi,

 

Just wondering if you have an idea why this may be happening.

 

Regards

Any ideas regarding this issue?

minnsey Atlassian Team May 16, 2018

Hi

I'm sorry I don't currently. Can you try making a back up and then removing the following files

%localappdata%\Atlassian\Sourcetree\bookmarks.xml
%localappdata%\Atlassian\Sourcetree\opentabs.xml

Removing these files means that Sourcetree will no longer be aware of any bookmarks/repositories and so there will be no tabs to open or git/hg processes to run.

Can you see if you still get the same freeing behaviour then? If you do it implies it is something to do with the rendering of the app or possibly REST call related. If Sourcetree then responds correctly it implies it is related to one or more repositories and the git/hg processes associated with it.


Sorry for the late reply, I did what you suggested and everything was fine momentarily and it then became unresponsive again. Since then I've been trying different solutions.

Today only by chance I had to work on another project which happens to be in a VM. I already had the repository setup in my VM and it's referenced in my Sourcetree which happens to be on my physical machine. All of a sudden Sourcetree has become responsive.

I thought I'd share this just in case someone else ends up with this issue. If you do have a repository cloned in your sourcetree but the source location is not accessible, it appears Sourcetree attempts to access it and finally gives up.  And this seems to be the reason why Sourcetree become unresponsive for a minute or more.

 

Thank for your help Michael

minnsey Atlassian Team Aug 14, 2018

Thanks for the information.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,927 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you