Sourcetree for windows install

I've seen other messages about Sourcetree for windows, the clickonce installer and firewall issues.

I installed sourcetree for windows beta a few weeks back on win7 64 bit and I love it. Upgrades have worked fine etc. Now all of a sudden the upgrade failed. I uninstalled/tried to re-install and I cant reinstall.

error is 'Unable to retrieve application files. Files corrupt in deployment'

ERROR SUMMARY

Below is a summary of the errors, details of these errors are listed later in the log.

* Activation of http://downloads.atlassian.com/software/sourcetree/windows/SourceTree.application resulted in exception. Following failure messages were detected:

+ Exception occurred loading manifest from file SourceTree.resources.dll: the manifest may not be valid or the file could not be opened.

+ File SourceTree.resources.dll is not a valid Portable Executable (PE) file.

+ File {0} is not a valid Portable Executable (PE) file.

I'm guessing that a firewall change at our company broke this, but I'm not going to get help unless I have more specifics. What needs to be opened up for this to work?

Thanks!

2 answers

Just to make sure I just tested a fresh install to rule out any issues with the files deployed in the latest update; that went fine.

I've only ever seen the 'corrupt' message when the download was interrupted or interfered with somehow, usually if it's a firewall or proxy issue then the error is about downloading. Is it possible that your corporate proxy or firewall interferes with downloaded files on the fly? The way ClickOnce works is it downloads a bunch of separate files over simple HTTP, they're each main deployment file like dlls/exes etc but simply given a '.deploy' extension. I wonder if there's some issue with the server in between you and downloads.atlassian.com detecting that it's downloading binaries (even with a different extension) and is filtering them out as a security measure?

Thanks Steve. This should be enough info for me to provide to our security folks to hopefully be able to sort this out.

-Joe

Sounds like you had this spot on. Our security folks added this to the "safe list" and everything works fine now.

Thanks for the help!

-Joe

Same problem here, we have a content filter. There is an offline installer available?

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published May 11, 2018 in Sourcetree

Tip from the team: debugging Sourcetree

Supported Platforms macOS Windows If you're reading this and it's not just educational… we know you're unhappy right now and apologize for that   We're dedicated to improving yo...

136 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you