It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Sourcetree for Mac (2.6.x) sends empty password to Bitbucket Server when Browsing it via REST API Edited

After upgrade of SourceTree to ver. 2.5.3 and 2.6.3 I cannot browse BitBucket repos anymore. SourceTree shows the error "The operation couldn’t be completed. (SDNetDomain error 7."

I've checked this with two BitBucket servers (both running ver. 4.12)

I captured authentication request and noticed that SourceTree doesn't send my password in Basic auth header (as seen it sends only base64-encoded username and colon):

GET /rest/api/1.0/users/ypetrov/repos?limit=%32%35 HTTP/1.1

Host: devbitbucket.netsertive.local:7990

Connection: keep-alive

Accept: */*

User-Agent: Sourcetree/134 CFNetwork/760.2.6 Darwin/15.3.0 (x86_64)

Accept-Language: en-us

Authorization: Basic eXBldHJvdjo=

Accept-Encoding: gzip, deflate



HTTP/1.1 401 Unauthorized

Server: Apache-Coyote/1.1

X-AREQUESTID: @X1HX1Kx121x3405x0

X-ASEN: SEN-4920128

WWW-Authenticate: Basic realm="Atlassian Bitbucket"

Content-Type: application/json;charset=UTF-8

Content-Length: 197

Date: Wed, 20 Sep 2017 06:01:12 GMT

{"errors":[{"context":null,"message":"Authentication failed. Please check your credentials and try again.","exceptionName":"com.atlassian.bitbucket.auth.IncorrectPasswordAuthenticationException"}]}

I wiped SourceTree preferences, then installed latest SourceTree. This didn't help.

Rollback to version 2.4.1 fixed the issue.

1 answer

0 votes
Manju Atlassian Team Sep 20, 2017

Hi @Yury Petrov

I just tried adding a bitbucket server account and was able to get a list of remotes in the repo browser window. I am guessing that there was an issue saving your password while adding the account. 

Can you please remove the account from accounts tab in preferences and any keychain item with the given host? And add the account again in preferences. This should ideally work. 

 

Thanks,
Manjunath
Sourcetree Mac Developer

That was my initial guess - that something is wrong with keychain. So I removed all entries related to bitbucket servers from keychain - still no luck. I even reproduced the problem on two different OS (Maveriks and El Captain) connecting to two different Bitbucket servers.

Need to note that after downgrade to 2.4.1 or 2.6.2 remote browsing works like a charm.

Is there any logs I can check in SourceTree app?

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,895 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you