It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Sourcetree creates 1KB BASE file while merging Edited

Hello,

Sourcetree creates 1KB BASE file while merging and merging is hence not possible. Command git merge-base commit1 commit2 returns the base commit that is of correct size (over 100 MB).

What to do to be able to merge, hence access the base file ? Does this have something to do with LFS ?

Thanks

1 answer

0 votes
Mike Corsaro Atlassian Team Jun 12, 2018

Hello! This might have something to do with LFS -- are the merge file sizes very large? Does this only happen in this repo?

Hello Mike,

thank you for your reply! It might indeed. However:

with this configuration for merge

local: 127 MB

remote: 110 MB

base: 109 MB are created

and with this configuration for merge

local: 127 MB

remote: 138 MB

base: 1KB

a 1KB base file (practically empty file) is created. I find yet no way which commit is git taking as base in a specific merge session. Apparently it cannot retrieve the base in latter case correctly. Do you have an idea ?

 

Thanks!

Further, the point is, it is not always the case that in the merge process a 1KB BASE file is created. For merge with some other branches it works fine as usual. For the cases with 1 KB BASE file, to find which base, I executed git merge-base commit1 commit2. The resulting commit is a normal file, non empty.

I have this issue with 1KB retrieved BASE file, since a short time (Monday). I tried to merge using git merge <sourcebranch> command and git mergetool command to merge and resolve conflicts, all without Sourcetree involved. Still the same problem. 

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Sourcetree for Windows - CVE-2019-11582 - Remote Code Execution vulnerability

A vulnerability has been published today in regards to Sourcetree for Windows.  The goal of this article is to give you a summary of information we have gathered from Atlassian Community as a st...

4,910 views 0 12
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you