Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Sourcetree crashing on startup

Operative System: macOS High Sierra 10.13.2 (17C88)

Issue starting date: 01-06-2018

Sourcetree version: 2.6.3a

Description:

Sourcetree app is crashing on startup even though I've upgraded it to the latest (2.6.3a) 

Screen Shot 2018-01-06 at 3.11.28 PM.png

I understand this issue had happened before due to some xCode distributions but I haven't updated my version in the last few days and yesterday it was working like a charm.

Anyone who could help me I would really appreciate it. Thanks!

1 answer

0 votes
bgannin Atlassian Team Jan 07, 2018

Please post the crash report so we have context for what the crash actually is. Thanks.

Hi @bgannin, thanks for your comment. Where can I take the crash report from?

Thanks in advance for your help!

bgannin Atlassian Team Jan 10, 2018

You'll find them in the sidebar of Console.

What console do you refer to? I can't open the app at all.

Thanks

bgannin Atlassian Team Jan 11, 2018

/Applications/Utilities/Console.app (or type Console in Spotlight Search)

I think this would be the report.

Jan 11 17:56:46 Diegos-iMac com.apple.xpc.launchd[1] (com.torusknot.SourceTreeNotMAS.4088[812]): Service exited due to signal: Illegal instruction: 4 sent by exc handler[0]

 Anything please let me know. Thanks!!!

Getting this same error. Started happening on the previous version, update to the absolute newest version but happens in both.

Have tried doing a complete delete of it and all preferences. But the minute I add in my repos, it crashes and keeps crashing.

Upon further testing, it's crashing as soon as I add a BitBucket repo. Swapped to using the Git-Fork app for now. Not having any issues with that crashing.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Sourcetree

Tip from the team: configure your repos for hosting goodness!

Supported Platforms macOS Windows We recently introduced support for additional hosting services such as GitHub Enterprise, GitLab (Cloud, Community Edition, Enterprise Edition), and...

3,250 views 4 5
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you